Closed Bug 1724030 Opened 3 months ago Closed 3 months ago

Red `Rpk` tasks after Bug 1709697: "TypeError: expected str, bytes or os.PathLike object, not generator"

Categories

(Firefox :: Installer, defect)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr78 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 --- affected

People

(Reporter: nalexander, Assigned: nalexander)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 obsolete file)

Clearly my refactoring for get_application_value is busted. I'll get on it.

Made a function yield a generator, forgot to consume it. Try build is at https://treeherder.mozilla.org/jobs?repo=try&revision=5c5babb3ffcd11951785137acf4519da5730a538.

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc7dff1c6f2c
Fix `Rpk` tasks after Bug 1709697: "TypeError: expected str, bytes or os.PathLike object, not generator". r?#build CLOSED TREE
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Status: RESOLVED → REOPENED
Flags: needinfo?(nalexander)
Resolution: FIXED → ---
Target Milestone: 92 Branch → ---

Clearing NI since this has landed, albeit folded into the reland of Bug 1709697.

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Flags: needinfo?(nalexander)
Resolution: --- → WORKSFORME
Attachment #9234712 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.