Closed Bug 1724062 Opened 4 months ago Closed 3 months ago

Test fission performance on autoland

Categories

(Testing :: Performance, task, P2)

Default
task

Tracking

(Fission Milestone:MVP, firefox-esr78 wontfix, firefox-esr91 wontfix, firefox90 wontfix, firefox91 wontfix, firefox92 wontfix, firefox93 fixed)

RESOLVED FIXED
93 Branch
Fission Milestone MVP
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- fixed

People

(Reporter: jesup, Assigned: alexandrui)

References

()

Details

(Whiteboard: fission-soft-blocker)

Attachments

(2 files)

Currently we only run fission tests on m-c; we should run them on autoland in order to get better alerts for fission-related regressions

(In reply to Randell Jesup [:jesup] (needinfo me) from comment #0)

Currently we only run fission tests on m-c; we should run them on autoland in order to get better alerts for fission-related regressions

Which Fission tests are we running on m-c but not autoland? Some of the performance tests?

We are running many other tests (mochitests, WPT, crashtests, reftests) on both m-c and autoland.

Flags: needinfo?(rjesup)

We're not currently running any Fission enabled performance tests (Talos, Raptor, AWSY) on autoland. We recently reduced tests running without WebRender, so I imagine we have some capacity to increase Fission testing.

:jmaher can you confirm if we have the necessary capacity? I imagine we would want to run AWSY, Talos, and high-value Raptor tests on autoland with Fission enabled.

Severity: -- → S3
Flags: needinfo?(jmaher)
Priority: -- → P2

we have capacity for fission perftests awsy, talos, high-value raptor on linux, win10, and osx10.15.

Looking forward to these getting enabled.

Flags: needinfo?(jmaher)

Note that we hope to enable Fission by default (for all users and tests) in 2021 Q4. Then we'll be able to shut off all these extra "fis" tests on mozilla-central and autoland.

Tentatively tracking this bug as soft blocker for Fission MVP. Running these perf tests on autoland doesn't block shipping Fission, but having them running soon would be nice. After we enable Fission by default in Q4, this bug will be obsolete because all tests will be Fission tests.

Fission Milestone: --- → MVP
Summary: Test fission on autoland → Test fission performance on autoland
Whiteboard: fission-soft-blocker

(In reply to Chris Peterson [:cpeterson] from comment #4)

Note that we hope to enable Fission by default (for all users and tests) in 2021 Q4. Then we'll be able to shut off all these extra "fis" tests on mozilla-central and autoland.

Will there be a way to disable Fission? Should we anticipate continuing to test with Fission disabled until we enable it for the majority of our release population?

Flags: needinfo?(cpeterson)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚GMT from comment #6)

(In reply to Chris Peterson [:cpeterson] from comment #4)

Note that we hope to enable Fission by default (for all users and tests) in 2021 Q4. Then we'll be able to shut off all these extra "fis" tests on mozilla-central and autoland.

Will there be a way to disable Fission? Should we anticipate continuing to test with Fission disabled until we enable it for the majority of our release population?

We don't intend to support users with Fission disabled. I know some "1proc" tests currently disable e10s. We'll still need to be able to disable both e10s and Fission for those "1proc" tests. But once Fission is the default for users, we won't need to run tests with e10s. Every test will hopefully be Fission or "1proc".

Note that Fission will ship on desktop in 2021 Q4 but won't ship on Android until 2022 H1, which may complicate the test transition. However, we might be able to run Android in a partial Fission mode to simplify the transition.

This will hopefully be an opportunity to remove -e10s and -fis from many test names. :)

Flags: needinfo?(cpeterson) → needinfo?(dave.hunt)

We can target variants based on platform so don't imagine the desktop/android differences will be much of a problem. Looking forward to the eventual simplification of our task names!

Flags: needinfo?(dave.hunt)
Assignee: nobody → aionescu
Status: NEW → ASSIGNED
Pushed by aionescu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66a4fa89f6cd
Test fission performance on autoland r=jmaher
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Setting status-firefox92=wontfix because we don't need to uplift this test change to Beta.

Pushed by aionescu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/721748f6d460
Fix talos perfdocs typo r=perftest-reviewers,alexandru.irimovici
Flags: needinfo?(rjesup)
You need to log in before you can comment on or make changes to this bug.