Calendar crashes when creating an event with an alarm

VERIFIED INVALID

Status

Calendar
General
--
critical
VERIFIED INVALID
16 years ago
12 years ago

People

(Reporter: Matt, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910

Yes, I've read the FAQ. Yes, I know this is probably a Netscape bug. 

Here is the sample ICS file:
**************************** BEGIN SNIP ********************************
BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
BEGIN:VEVENT
UID
 :979849348
SUMMARY
 :test event 2
CLASS
 :PUBLIC
DTSTART
 :20021010T122000
DTEND
 :20021010T132000
DTSTAMP
 :20021003T181809Z
BEGIN:VALARM
TRIGGER
 ;VALUE=DURATION
 :-PT15M
END:VALARM
END:VEVENT
END:VCALENDAR
***************************** END SNIP *****************************
If you comment out the lines "BEGIN: VALARM" through "END:VALARM", the calendar
starts fine. I'm afraid that if this were reported to Netscape, I'd get the "not
offically support" speech.. the Calendar feature is what pulled me away from
Outlook and IE. I really need this.. 

Reproducible: Always

Steps to Reproduce:
1.Open Calendar through Netscape 7
2.Create a new event. you only need to fill in the Title and check the alarm box.
3.Click OK.

Actual Results:  
Netscp.exe crashes

Expected Results:  
Mozilla is fine..
(Assignee)

Comment 1

16 years ago
Was calendar running when it crashed, or just Netscape?
Also, if you go to Edit->Preferences, what options do you have for alarms? Open
window and sound alarm, or just one of those?

Also, what version of the calendar are you trying to run?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Netscape was running. I went to Window, Calendar in the menus to start the
Calendar..  

Under Edit, Preferences, the options selected are:
Play a sound - checked
show an alarm box - checked 

I am using the latest version : Mozilla Calendar 2002092009-cal 

i installed it a few days ago.. I have verified the issue on another PC as well..
(Assignee)

Comment 3

16 years ago
Since Netscape is based on Mozilla 1.0.1, I don't think that the latest builds
will work on it.
Try installing calendar 0.8 and see if you still have the problems (you should
be able to upgrade back to the latest if the issue isn't solved).
(Reporter)

Comment 4

16 years ago
That looks like it solved the problem.. Thank you very much for the help.. I
assumed Netscape7 was using the latest version since it was just released.. Keep
up the great work.. I'll let you know of any further issues.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
VERIFIED
Status: RESOLVED → VERIFIED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: colint → general
You need to log in before you can comment on or make changes to this bug.