Extraneous vertical line on selected message near scrollbar

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021003 Netscape/7.0b1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021003 Netscape/7.0b1+

There is an extra vertical line near the scrollbar when message selection occurs.

It's different in appearance from the same selection/focus ring in the folder
pane, because this one has a (1px?) gap between the scrollbar/column border.

Reproducible: Always

Steps to Reproduce:
1. Focus a message in the 3-pane.
2. Look near the scrollbar at the focus ring.
3.

Actual Results:  
Focus ring contains a (1px?) space between scrollbars and it.

This occurs on Modern especially, but I'll have to double-check older builds on
Classic to see if it's a problem there, we're not as noticable with Classic.

Expected Results:  
Should look like the folder pane's focus ring.

Screenshot forthecoming.
Created attachment 101594 [details]
Screenshot
Confirming.  Setting QA to myself.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, ui
QA Contact: olgam → stephend
Created attachment 101597 [details]
Branch Screenshot

Comment 4

15 years ago
I can be reached via Aim as RBozie or ICQ 1508821
I can reproduce this, but if I make the window just 1 or 2 pixels wider, it goes
away.

when I see it, repaiting doesn't help.

maybe a rounding error in the tree painting code?

cc jan varga.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 6

12 years ago
WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051020 SeaMonkey/1.1a
QA Contact: stephend

Comment 7

12 years ago
Aqualon	agrees wfm Gecko/20051103 SeaMonkey/1.0b
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.