Closed Bug 1724622 Opened 11 months ago Closed 1 month ago

Protections popup toast is missing a fade/cancel animation

Categories

(Firefox :: Protections UI, defect, P5)

Firefox 92
defect

Tracking

()

RESOLVED FIXED
102 Branch
Tracking Status
firefox102 --- fixed

People

(Reporter: aminomancer, Assigned: aminomancer)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

  • Click the tracking protection icon.
  • Click the toggle.

Actual results:

  • The tracking protection toast popup appears...
  • It fades in and translates down 70px like a normal panel...
  • But after 3 seconds, it just disappears instantaneously without a fade animation.

Expected results:

I think this is because the script uses PanelMultiView.hidePopup instead of this._protectionsPopup.hidePopup(true). I tried changing this one line and it fixed the problem for me. So I think line 2151 should just be changed from this:

PanelMultiView.hidePopup(this._protectionsPopup);

to this:

this._protectionsPopup.hidePopup(true);

The Bugbug bot thinks this bug should belong to the 'Firefox::Protections UI' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Protections UI
Status: UNCONFIRMED → NEW
Ever confirmed: true

When the tracking protection toast popup closes on a timer, it doesn't
smoothly fade out, because it uses PanelMultiView.hidePopup instead of
panelNode.hidePopup. The static method on PanelMultiView ultimately
calls panelNode.hidePopup, but it doesn't have a parameter for enabling
the animation so it passes nothing to that method. This patch extends
PanelMultiView's hidePopup class methods to add an optional animate
parameter, and adds that parameter to the toast popup's hidePopup call.
This should slightly reduce the speed of part of
browser_protectionsUI.js but I don't think it affects any other tests.

Assignee: nobody → shmediaproductions
Status: NEW → ASSIGNED
Severity: -- → S4
Priority: -- → P5
Blocks: 1769813
Pushed by pzuhlcke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/31b0368654db
Fix missing ETP toast popup animation. r=pbz,Gijs
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch
Blocks: 1773589
You need to log in before you can comment on or make changes to this bug.