Collapsing menubar causes crash - sometimes.

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
19 years ago
16 years ago

People

(Reporter: chimera, Assigned: Peter Trudelle)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Strange bug - I'm not making this up :)
Won't be surprised if it is hard to reproduce.

Do the following exactly
1) start mozilla-apprunner
2) Using mouse, hover the pointer over the File menu so that the menu lights up.
3) click on the roll-up for the main menu
4) click on the roll-down for the main menu
5) click on the roll-up for the main menu
6) click on the roll-down for the main menu
7) Mozilla crashes.

Sometimes for mysterious reasons mozilla doesn't crash. I've had a lot of
trouble to find instructions that work every time on my config, I dunno whether
the above instructions will work for others.
Essentially,
1) click and hover and pointer at as many things as possible.
2) roll-up the menu.
3) click and hover and pointer at as many things as possible.
4) roll-down the menu.
5) If (crash) work out why else goto step 1

Several observations.
- If you do it carefully, ie don't hover the pointer over the menu text,
rollup/down won't crash the browser.
- You can repeat it using the menu under the options
"Debug->XPToolkit->XP Menus". This shows it isn't a main menu bug, but a widget
problem.
- The File menu isn't special, though makes for more clear instructions.
- no error messages on command-line. return code is 0 (ie "echo $?") Though the
script file mozilla-apprunner could be masking the actual error code. (?)
- No core file produced.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 1

19 years ago
I'm not sure what you mean by "roll-up".  Using today's Linux opt bits, I cannot
reproduce this by clicking on the menu title to repetitively display and close
the menu. Resolving as worksforme, if you are still seeing this, please re-open
with clear, exact steps to reproduce, and/or some details about your
environment.
(Reporter)

Comment 2

19 years ago
The original bug report was with respect to Milestone 10 on Linux with
Build 1999100808. I've since downloaded the 1999102608 build.
However, the interface has changed slightly. The menu looks different
and XP Menu is NOT used anymore - that could be why you did not detect
the bug. You may have to go back to M10.
Not sure whether this can be called resolved as the original problem
may remain, just that you can't get to it anymore.
Nonetheless, I could not crash apprunner with the demo XP Menu via
"Debug->XPToolkit->XP Menu".

BTW - The original problem was on a updated-RH60. The original M10 bug
exists with both "Gnome with Enlightenment" and "Fvwm2".

When I said roll-up/down, there are approx 5 pixel wide bars to the left
of toolbars (and menus in M10). If you click on them, the toolbar
disappears replaced by a horizontal bar 5 pixels high. This saves room.
It is also in Netscape 4.x. Not sure what the technical term for them are.
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED
Summary: Roll-down a menu cause crash - sometimes. → Collapsing menubar causes crash - sometimes.
(Assignee)

Comment 3

19 years ago
Oh, I get you. The generic term for these is 'grippies'.  The gesture you're
talking about is 'collapse the menubar' changing summary and reopening

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 4

19 years ago
Clearing WORKSFORME resolution due to reopen of this bug.
(Assignee)

Comment 5

19 years ago
Cannot collapse menubar in current builds.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → REMIND
(Assignee)

Comment 6

19 years ago
resolving as remind, reopen if menubars become collapsible again, and this bug
can be reproduced.

Comment 7

18 years ago
Adding crash keyword
Keywords: crash
REMIND is deprecated per bug 35839.
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
WFM.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.