Closed Bug 1724878 Opened 4 months ago Closed 4 months ago

Search mode chiclet close button in address bar has low contrast in dark mode

Categories

(Firefox :: Theme, defect, P2)

Firefox 92
defect
Points:
1

Tracking

()

VERIFIED FIXED
93 Branch
Iteration:
93.1 - Aug 9 - Aug 22
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox91 --- unaffected
firefox92 + verified
firefox93 + verified

People

(Reporter: ke5trel, Assigned: harry)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Enable Dark theme.
  2. Type "duck" in the address bar and press Tab to select "Search with DuckDuckGo".

The search mode chiclet close symbol is black on a dark background making it difficult to see.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6ffeb2a3d80381264c0ad9329b4d07b3f343a4ca&tochange=c7687ceeff3f99555aa7d3f744da33952aef236f

Regressed by Bug 1698814.

Harry, would you look into this?

Severity: -- → S3
Flags: needinfo?(htwyford)
Priority: -- → P2

[Tracking Requested - why for this release]:
Minor UI regression that causes low contrast on an element.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 93.1 - Aug 9 - Aug 22
Points: --- → 1
Flags: needinfo?(htwyford)

This fixes the bug but retains the fix for the unfiled bug I mentioned in this Phabricator comment. Basically we want fill:var(--toolbar-field-color) when the Urlbar is unfocused and fill:var(--toolbar-field-focus-color) when it's focused.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97a6a6951ad6
Apply fill:currentColor to #urlbar-search-mode-indicator-close. r=dao
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

The patch landed in nightly and beta is affected.
:harry, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(htwyford)

Comment on attachment 9235989 [details]
Bug 1724878 - Apply fill:currentColor to #urlbar-search-mode-indicator-close. r?dao!

Beta/Release Uplift Approval Request

  • User impact if declined: Minor contrast regression in the address bar. See screenshot in comment 0.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line CSS change.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9235989 - Flags: approval-mozilla-beta?

Comment on attachment 9235989 [details]
Bug 1724878 - Apply fill:currentColor to #urlbar-search-mode-indicator-close. r?dao!

Approved for 92.0b5.

Attachment #9235989 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is verified fixed in the latest Fx 93.0a1 nightly and latest beta Fx92.0b9 on Windows 10 and Ubuntu 20.04. The 'close' button for the chiclet is correctly displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.