Do not allow ctrl+dragging (or remove the + pointer) in Toolbar Customization

RESOLVED FIXED in Future

Status

()

RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: cplyon, Assigned: jhenry)

Tracking

unspecified
Future
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-aviary1.0)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using build 20021003 on WinXP

Steps to Reproduce:
1. Go to Customize Toolbars.
2. Hold down Ctrl and drag an item (on the toolbar or in the dialog).
3. Mouse cursor has a +, indicating the item will be copied.

Expected Results:
Item gets copied.

Actual Results:
Item gets moved.

Comment 1

16 years ago
I don't think we want to copy the item (at least not most of them). But we
should fix the pointer to not suggest a copy. 
Assignee: hyatt → hewitt
Summary: Ctrl-dragging does not copy customization items → Ctrl-dragging does not copy customization items

Comment 2

16 years ago
Chris, is it alright with you if I morph this bug into "Do not allow
ctrl+dragging or remove the + pointer". If not then I'll mark this won'tfix and
file a new bug.
(Reporter)

Comment 3

16 years ago
Fine by me.
Summary: Ctrl-dragging does not copy customization items → Do not allow ctrl+dragging (or remove the + pointer) in Toolbar Customization

Updated

15 years ago
Target Milestone: --- → After Firebird 1.0

Comment 4

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla
(Assignee)

Comment 5

14 years ago
Created attachment 151848 [details] [diff] [review]
Patch

This patch makes DROPEFFECT_MOVE the only valid action. If you try to copy the
item by holding ctrl, you will get the "no" symbol (circle with a line through
it) and the drop won't go through. That seems to be the standard windows way of
indicating a drag-and-drop attempt is invalid. I can't find a way to make it
simply ignore the ctrl press and always act like a move without mucking with
Gecko's internals; see
http://lxr.mozilla.org/aviarybranch/source/widget/src/windows/nsNativeDragTarget.cpp#211
if you're interested in why.
(Assignee)

Updated

14 years ago
Assignee: hewitt → jhenry
Status: NEW → ASSIGNED
(Assignee)

Comment 6

14 years ago
Comment on attachment 151848 [details] [diff] [review]
Patch

This is a trivial polish fix, but it makes us more consistent which is a good
thing.
Attachment #151848 - Flags: review?(mconnor)
I'll look at this later tonight, almost done!
Comment on attachment 151848 [details] [diff] [review]
Patch

Actually, on linux it does what you want it to do (just drag with the right
icon), if it just plain doesn't work on Windows that's fine, it'll clearly tell
people trying to do it that it won't work.
Attachment #151848 - Flags: review?(mconnor) → review+
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Whiteboard: fixed-aviary1.0

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.