Closed Bug 1725022 Opened 3 years ago Closed 3 years ago

AVIF missing the PixelInformationProperty (pixi) are rejected as invalid

Categories

(Core :: Graphics: ImageLib, defect, P2)

Firefox 93
All
Unspecified
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox91 --- unaffected
firefox92 --- disabled
firefox93 --- verified

People

(Reporter: ksenia, Assigned: jbauman)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

This was initially reported in https://github.com/webcompat/web-bugs/issues/82816

STR:

  1. Visit https://www.dailymail.co.uk/home/index.html in Firefox Nightly 93.0a1 (2021-08-10) and observe the site

Expected:
Images do not load
Actual:
Images load

The following is displayed when visiting a link to one of the images https://i.dailymail.co.uk/1s/2021/08/10/21/46526771-0-image-m-7_1628626216775.jpg :

The image “https://i.dailymail.co.uk/1s/2021/08/10/21/46526771-0-image-m-7_1628626216775.jpg” cannot be displayed, because it contains errors.

From mozregression:

12:52.35 INFO: Narrowed integration regression window from [0c7d036a, 6d2bbba5] (3 builds) to [0c7d036a, bb07fcce] (2 builds) (~1 steps left)
12:52.35 INFO: No more integration revisions, bisection finished.
12:52.35 INFO: Last good revision: 0c7d036ab79c4bb37ad3c38ae5232c47e209eb84
12:52.35 INFO: First bad revision: bb07fcce356745addfc703bc043963f0abe7dea5
12:52.35 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0c7d036ab79c4bb37ad3c38ae5232c47e209eb84&tochange=bb07fcce356745addfc703bc043963f0abe7dea5

Hi Jon, could you take a look please?

Flags: needinfo?(jbauman)

This is the AVIF served for https://i.dailymail.co.uk/1s/2021/08/10/21/46526771-0-image-m-7_1628626216775.jpg. It's invalid because it lacks the PixelInformationProperty (pixi) which is mandatory per MIAF (ISO/IEC 23000-22:2019) § 3.6.6 Pixel information:

The pixel information property shall be associated with every image that is displayable (not hidden) and should be associated with all images, and shall be supported by the MIAF renderer.

The AOM AVIF validator confirms:

[miaf][Rule #26] Error: Found no 'pixi' associated for 1 displayable (not hidden) images (ItemIds={1})

As a workaround, it's possible to reduce the standards compliance by setting the image.avif.compliance_strictness pref to 0, which will allow these invalid files to be displayed.

Flags: needinfo?(jbauman)

Due to a bug (now fixed) in libheif, AVIF images lacking this property were created and may remain in the wild. After receiving https://bugs.chromium.org/p/chromium/issues/detail?id=1198455, Chrome relaxed their check for this requirement and it is unclear whether it will be reinstated.

Discussion is underway to modify MIAF to allow the pixi property to be omitted, but it's unclear whether or when that will happen. Since AVIF is a very new format, it's preferable to have these errors surfaced in the hopes that the invalid files can be fixed, but it remains an open question what the long-term approach here will be.

Blocks: AVIF
Severity: -- → S3
Priority: -- → P2
Summary: Images do not load on dailymail.co.uk with image.avif.enabled=true → AVIF missing the PixelInformationProperty (pixi) are rejected as invalid

Set release status flags based on info from the regressing bug 1682995

Depends on: 1726410

This was fixed (by relaxing the enforcement of the pixi requirement) by the mp4parse-rust update in bug 1726410, but considering the prevalence of these invalid images in CDNs, we should probably consider an uplift for 92.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Assignee: nobody → jbauman
Target Milestone: --- → 93 Branch

AIUI bug 1727448 will make this problem go away for 92?

Flags: needinfo?(jbauman)

(In reply to Julien Cristau [:jcristau] from comment #6)

AIUI bug 1727448 will make this problem go away for 92?

Yes, that's the idea.

Flags: needinfo?(jbauman)
Flags: qe-verify+

I was able to reproduce the issue on Nightly 93.0a1 and Verified as fixed on:
Win10 - Nightly 94.0a1 and Beta 93.0b7
Ubuntu 20.4 - Nightly 94.0a1 and Beta 93.0b7
MacOS11- Nightly 94.0a1 (2021-09-19) and Beta 93.0b7

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: