Closed Bug 172534 Opened 18 years ago Closed 18 years ago

text attributes (e.g. of abbr) do not properly handle carriage returns

Categories

(Core :: Layout, defect)

PowerPC
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 67127

People

(Reporter: stevenj, Assigned: attinasi)

References

()

Details

Attachments

(1 file)

I first noticed this problem when using the abbr tag, as shown in the above URL.
 This tag has an attribute title="..." where the "..." type is %Text = CDATA
according to the HTML 4.01 DTD at w3c.org.  CDATA, according to the spec, should
"Replace each carriage return or tab with a single space."  Mozilla seems to
instead simply delete carriage returns.

I am using 1.0.0 on Debian/PowerPC; I haven't checked other platforms/versions.
 If you let the mouse hover over "AFA" in my example, the abbreviation title
will pop up and is missing whitespace where the carriage return is in the source
document.  (The second abbreviation, "ASA", looks correct because I inserted a
manual space character before the carriage return in the title attribute.)
Attached file test case, same as URL

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.