Closed Bug 1725629 Opened 1 year ago Closed 1 month ago

Menuitem lags in Bookmarks menu

Categories

(Core :: Performance, defect, P3)

Firefox 93
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dr2017, Unassigned, NeedInfo)

References

Details

(Whiteboard: QA-not-reproducible)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Attempted to use bookmarks from the Menu bar in Windows 7.

Actual results:

When opening an inner menu from a bookmarks folder that has a substantial number of bookmarks the highlighted menuitem lags the mouse movement. If you move the mouse quickly down the menu it may take a a second or two for the highlighted bookmark to catch up with it.

Expected results:

Tested in Windows 10 and the mouse and highlighted menuitem are synchronized, the problem occurs in Windows 7, classic theme.

The Bugbug bot thinks this bug should belong to the 'Firefox::Bookmarks & History' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Bookmarks & History

Similar issue Bug 1724617 in Windows10.

Hi, can you post a video or screenshots of the area where it starts to lag ?
Also how many bookmarks do you need in order for the issue to appear?

Does this issue happen with a new profile? Here is a link on how to create a new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

Does this issue occur in the latest nightly version of firefox? Here is a link from where you can download it: https://www.mozilla.org/en-US/firefox/channel/desktop/

Please let us know
thanks

Flags: needinfo?(dr2017)

Hi,

Bug 1724617 from Alice0775 White has a video in the link above. My experience it's doing the same exact thing. Sometimes it's with bookmarks in the very first row of a bookmark folder but more consistently when two or three folders in and it has 15 or more bookmarks.

This behavior I noticed from the very first 93.0 nightly and it is still continuing and with a fresh profile as well. I have not tested it v92.0 but v91esr is not a problem.

Flags: needinfo?(dr2017)

Lets mark as a duplicate of bug 1724617 since they seem to be the same.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Whiteboard: QA-not-reproducible
Component: Bookmarks & History → Performance
Product: Firefox → Core
See Also: → 1730362
See Also: → 1729756
See Also: → 1731133

Alice0775, can you explain why this was reopened after being closed as a duplicate? I can't quite make sense of the history on this bug.

Flags: needinfo?(alice0775)

(In reply to Doug Thayer [:dthayer] (he/him) from comment #6)

Alice0775, can you explain why this was reopened after being closed as a duplicate? I can't quite make sense of the history on this bug.

Similarly, bug 1724617 points out that mouse clicks become temporarily unresponsive as well as lag.
The lag is not a recent regression I think.
But the temporary unresponsive is regression from Bug 1722258.

So, I think this is different.

Flags: needinfo?(alice0775)
See Also: 1729756
See Also: 1730362

202nine, in the latest builds are you still seeing the menuitem lag that caused you to log this bug?

Flags: needinfo?(dr2017)

Anyone seeing the lag, it would be great if one could create a performance profile
https://profiler.firefox.com/
and share the link which 'upload local profile' button creates.

Severity: -- → S3
Priority: -- → P3

With no answer from the reporter, we don’t have enough data to reproduce and/or fix this issue. Please reopen or file a new bug with more information if you see it again.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.