padding-right & padding-left given a <percentage> value in a table is partially ignored

VERIFIED DUPLICATE of bug 30802

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 30802
15 years ago
15 years ago

People

(Reporter: Tobias Burnus, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [QA-P3], URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Hi. This has been observed with Mozilla 1.0 and 1.2a-CVS.
  http://www2.physik.fu-berlin.de/test.html
contains a
  "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"
document, which validates (both HTML and CSS).

I use
  p.footer {padding-right: 5%; padding-left: 5%;}
and in the table. The first paragraph gets indented (including automatical
wrapping). As soon as I start a new <p> paragraph or a new <br> line. This line
is no longer indented.

Comment 1

15 years ago
when the padding-right and padding-left is provided in <perecentage> value, the
padding is not registered in the right way.
Whereas, when the value is in <length> unit, the padding works fine.

see the attached testcase. happens on all platforms

could not locate a duplicate bug.

Keywords: testcase
OS: Linux → All
Priority: -- → P3
Whiteboard: [QA-P3]

Comment 2

15 years ago
Created attachment 101715 [details]
testcase showing how <percentage> & <length> values behave for padding style

1st table :- text within one div with no line break. Wraps automatically.

2nd Table :- text within one div with line break provided. sentence before the
line break is longer than the sentence after the line break. First sentence
wraps automatically. 2nd sentence does not register the padding-left style.

3rd Table:-  text within one div with line break provided. sentence after
theline break is longer than the sentence before the line break. First sentence
wraps automatically. 1st sentence does not register the padding-left style.

4th Table :- 2 paragraphs within the cell. 1st paragraph wraps. 
2nd paragraph  does not register the padding-left style.

Updated

15 years ago
Summary: padding-right + -left in a table is partially ignored → padding-right & padding-left given a <percentage> value in a table is partially ignored

Comment 3

15 years ago
sorry.... in comment 2 , there is a slight change in decription for Table 3....

3rd Table:-
===========
text within one div with line break provided. sentence after
the line break is longer than the sentence before the line break. 2nd sentence
wraps automatically. 1st sentence does not register the padding-left style.
The wrapping issues are the way table sizing works.  The failure of padding to
apply at some times is, IIRC, a duplicate.

*** This bug has been marked as a duplicate of 30802 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
Thanks David!
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.