Closed Bug 1725737 Opened 6 months ago Closed 5 months ago

"Folder is null" after update, smart folder "Sent" empty

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird92+ fixed)

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird92 + fixed

People

(Reporter: pmbiesiada, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36

Steps to reproduce:

  1. update from 78.13.0 x64 to 91.0 x64
  2. start TB, wait a moment
  3. select Sent unified folder

Actual results:

the message list is empty

Expected results:

show sent items list = messages that were sent; they are visible in each account in account's Sent folder

Deleting *.msf files in profile folder didn't helped.
Add-ons disabled didn't helped.
Safe mode didn't helped.
There are both IMAP and POP accounts.

Blocks: tb91found
Component: Untriaged → Folder and Message Lists

I'm not able to reproduce this issue at first try, could you please provide more info?

Are you on Windows?
Are you using only the Unified View or are other folder modes active?
Can you try changing the folder modes? To do that, you can go in the menu View > Folders > Check and uncheck various modes to see if the issue happens consistently.
Would you be able to try on a fresh installation? Maybe on another machine.
Would you be able to temporarily remove the POP account and see if the issue remains?

No worries if you can't do some of these things.

I've attached screenshot of an error message that tells there is missing something like a folder.
This happened exactly after update from 78.13.0 to 91.0.

Yes, I am on Windows 10 Pro x64 PL, updated.

Only unified view.
Changing views does not help. Does not change anything.

When on Drafts folder (one above, empty), changing to Sent does not change messages list - error gives no action, the process of listing emails is interrupted.
When on Archives (one below, there are messages) does the same but changing to Sent does not clear the message list so I see Archives still (even after changing folder to Sent).

Fresh install would be without all settings, I have 24 accounts.
There are 22 POP accounts and 2 IMAP.

I suspect some missing folder or situation that TB expects folder when there is file with name "Sent".

This is the code that seems to be failing:
https://searchfox.org/comm-central/rev/6820aaa407ab48a2c1b7a7477015e0dac1dc5daf/mail/modules/DBViewWrapper.jsm#982-985

Potentially, we could fix this by filtering out null folders (!folder?.isServer) but we should first identify why this is happening in 91 and not 78, and what's being added in the virtual search folders that is not an actual folder.

Pinging Magnus to see if he has some insights on this, or if he can reproduce it.

Flags: needinfo?(mkmelin+mozilla)

I can't reproduce, but I can see how it would be a problem if for some reason bad data got (left) into the searchFolderUri.

Flags: needinfo?(mkmelin+mozilla)
Assignee: nobody → mkmelin+mozilla

Can you please share any kind of workaround or how to fix this problem in that particular state?
Is there any preference or settings that could be edited to solve that?
For now no grouped Sent items are visible, need to go through each Sent folder for all accounts...

We will land a fix and get it uplifted to 91. Probably into 91.1.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 93 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a8a654e6fb83
ignore non-existing (no longer existing?) folders when finding search folders. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Comment on attachment 9236304 [details]
Bug 1725737 - ignore non-existing (no longer existing?) folders when finding search folders. r=aleca

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: problems with search folders / unified view (can't see messages there)
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): should be safe

Attachment #9236304 - Flags: approval-comm-esr91?
Attachment #9236304 - Flags: approval-comm-beta?

Comment on attachment 9236304 [details]
Bug 1725737 - ignore non-existing (no longer existing?) folders when finding search folders. r=aleca

[Triage Comment]
Approved for beta

Attachment #9236304 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9236304 [details]
Bug 1725737 - ignore non-existing (no longer existing?) folders when finding search folders. r=aleca

[Triage Comment]
Approved for esr91

Attachment #9236304 - Flags: approval-comm-esr91? → approval-comm-esr91+
Duplicate of this bug: 1727727

I have 91.0.3 and it still does not show messages from the IMAP accounts.

You need to log in before you can comment on or make changes to this bug.