Closed Bug 1725955 Opened 1 year ago Closed 1 year ago

Thunderbird 91.0 when accessing Preferences memory usage climbs until max and program hangs

Categories

(Thunderbird :: Preferences, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1642415

People

(Reporter: frano.toich, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36

Steps to reproduce:

Open Thunderbird
Select Preferences from the Tools menu

Actual results:

Program hangs
Memory usage begins to climb until at reaches max and stays there
Program becomes unresponsive

Expected results:

Be able to select options in Preferences

Does problem go away if you have started in safe/troubleshooting
mode? https://support.mozilla.org/en-US/kb/safe-mode-thunderbird

Flags: needinfo?(frano.toich)

I have tested in safe/troubleshooting mode and it works fine.

Flags: needinfo?(frano.toich)

Also bug 1725974
Caching issue?

Blocks: tb91found
Flags: needinfo?(alessandro)

No idea, I haven't worked on this section for a while, maybe since 78, Khushil worked on the Preferences tab extensively.
Maybe Geoff has some insights on this?

Flags: needinfo?(alessandro) → needinfo?(geoff)

I have no idea. Comment 2 says it works in safe mode, so that suggests to me there's some add-on issue.

Flags: needinfo?(geoff)

Indeed, that means it's an add-on causing it.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

Or something cache related.
Reporter, do you have any add-ons installed? Tools > addons > extensions

Flags: needinfo?(frano.toich)
See Also: → 1725974

I have no add-ons installed.

I suspect it may well be a caching issue. I replaced the hard drive on my laptop and re-installed Windows 10. I simply copied the Thunderbird profile folder over from a previous version of Thunderbird on the previous hard drive, installed TB v91.0 on the new hard drive and everything began working as expected (except the Preferences). There was no need for me to recreate the user account settings - all my cached emails were simply there and new emails arrived as expected.

Is there any way to run a verification to check the consistency of the cached content?

Is there an add-on folder in the previous version which may have been copied across that could be causing an issue?

In any event - it would be good to update the code in the program to prevent the exhaustive use of system memory and instead prompt with a pop-up indicating a cache or add-on inconsistency. My suggestion.

Flags: needinfo?(frano.toich)

(In reply to Magnus Melin [:mkmelin] from comment #6)

Indeed, that means it's an add-on causing it.

Other possibilities includes graphics.

In normal mode Help > More troubleshooting info. Copy or screen shot the graphics section and attach the file to this bug report.

Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(frano.toich)
Resolution: INVALID → ---
See Also: → 1726512
See Also: 17265121726651

The next step is probably to test whether disabling webrender helps.
Open a command prompt on windows and do
SET MOZ_WEBRENDER=0
Then start thunderbird.exe from the command prompt.

(In reply to Wayne Mery (:wsmwk) from comment #10)

The next step is probably to test whether disabling webrender helps.
Open a command prompt on windows and do
SET MOZ_WEBRENDER=0
Then start thunderbird.exe from the command prompt.

Okay, have just tried that now and no improvement. Same result.

Flags: needinfo?(frano.toich)

Frustrating, eh?

open the error console (command+shift+J), hit the trash can to delete the current contents. then arrange thunderbird windows so the console won't be blocked and is still visible when you click on preferences. What shows in the error console?

(In reply to Wayne Mery (:wsmwk) from comment #13)

Frustrating, eh?

open the error console (command+shift+J), hit the trash can to delete the current contents. then arrange thunderbird windows so the console won't be blocked and is still visible when you click on preferences. What shows in the error console?

I appreciate all your time and assistance with this Wayne. This is the first thing to begin to look promising.

It is definitely looping - explaining the steady increase in memory usage until it is maxed.

I will see if I can upload a screenshot of it here.

(In reply to Frano Toich from comment #14)

(In reply to Wayne Mery (:wsmwk) from comment #13)

Frustrating, eh?

open the error console (command+shift+J), hit the trash can to delete the current contents. then arrange thunderbird windows so the console won't be blocked and is still visible when you click on preferences. What shows in the error console?

I appreciate all your time and assistance with this Wayne. This is the first thing to begin to look promising.

It is definitely looping - explaining the steady increase in memory usage until it is maxed.

I will see if I can upload a screenshot of it here.

https://ibb.co/xG6RSxM

The messages look like coming from localization. What locale are you using? From your Troubleshoot information you have the en-GB language pack installed, can you try to remove it? If it was installed with an en-GB build can you try an en_US only build?

I tried an en-US TB 91 with en-GB language pack installed and activated and have no issues. I see the override messages once and that's it. Everything is working.

I've been working with someone use who sees this problem and is using en-GB

Depends on: 1726380

Sorry, I duplicated this issue with bug #1727939. I use fr-FR locale

Just tried my different extensions by disabling them, and French language pack seems to be the problem

May be bug 1642415.

See Also: → 1642415

The about:support data in this bug is definitely that.

That's an en-GB build (intl-locale-default = en-GB) with an en-GB langpack on top (langpack-en-GB@thunderbird.mozilla.org).

Ok, let's dupe it.

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → DUPLICATE

Have just upgraded to the latest release of Mozilla Thunderbird v91.1.0 64bit on Windows 10 Pro and the same issue persists. Only improvement is that the Preferences page actually loads successfully now will the memory leak continues.

If bug 1642415 is/was only about incomplete fallback for the case of same language pack on top of same locale build, maybe there's something more involved here. Xref bug 1728744

(In reply to Wayne Mery (:wsmwk) from comment #1)

Does problem go away if you have started in safe/troubleshooting
mode? https://support.mozilla.org/en-US/kb/safe-mode-thunderbird

In my case Troubleshooting mode does NOT stop the memory bloat.

See Also: 1642415

From a tracking/prioritization/support POV, as a general rule it's less than ideal to close a major open Thunderbird issue to a core bug, especially one that hasn't yet been uplifted to fix us. Unless it's been concluded we don't need the uplift of bug 1642415?

Flags: needinfo?(mkmelin+mozilla)

Fixing this one in bug 1728744. Hope that covers the cases we have...

Flags: needinfo?(mkmelin+mozilla)
You need to log in before you can comment on or make changes to this bug.