xml files don't display

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
major
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: Juan Pablo Alcaraz, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Overview Description:
I can not see a xml document with its own .css file

Steps to Reproduce:
1) Cut and paste the xml text in a xml file.
2) Load it

Actual Results:
I can not see it with the .css styles.

Expected Results:
It must to show the text with .css styles

Build Date & Platform Bug Found:
1999102516

Additional Builds and Platforms Tested On:
nop

Additional Information:
It works with IE5
I send you the xml content and the .css content



============= norma.css =========


/* Use Times New Roman for default font */
$DOCUMENT {
  font-family: "Times New Roman";
  font-size: 12pt;
  margin-top: 5px;
  margin-left: 5px;
}

$COMMENT {
  display: block;
  color: purple;
  white-space: pre;
}

$PROCINS {
  color: black;
  background-color: #c0c0c0;
}

norma, para {
  display: block;
}

para {
  font-family: Courier;
  font-size: 9pt;
  color: navy;
}








======== file.xml ==========

<?xml version="1.0"?>
<!-- DOCTYPE norma SYSTEM "norma.dtd" -->
<?xml-stylesheet href="norma.css" type="text/css"?>
<norma>
<para>             BANCO CENTRAL DE LA REPUBLICA ARGENTINA</para>
<para>__________________________________________________________________</para>
<para>                     COMUNICACION  " A "  2620        I   14/11/97</para>
<para>__________________________________________________________________</para>
<para>A LAS ENTIDADES FINANCIERAS:</para>
<para/>
<para>                        Ref.: Circular
                              RUNOR 1 - 248.
                              CAMCO 1 - 97.
                              Transferencias de fondos entre cuen-
                              tas  corrientes de entidades finan-
                              cieras abiertas en el Banco Central</para>
<para/>
<para/>
<para/>
<para/>
<para>          Nos dirigimos  a Uds.  para informarles  que se  ha dis-
puesto prorrogar  los terminos  de la Comunicacion "A"  2604 hasta
el dia 21 de noviembre proximo inclusive.</para>
<para/>
<para/>
<para>          Saludamos a Uds. muy atentamente.</para>
<para/>
<para/>
<para>                           BANCO CENTRAL DE LA REPUBLICA ARGENTINA</para>
<para/>
<para/>
<para/>
<para/>
<para>            Hector O. Biondo              Alejandro L. Saravia</para>
<para>           Sugerente General             Subgerente General de</para>
<para>            de Operaciones             Informatica y Organizacion</para>
<para/>
</norma>

Comment 1

18 years ago
Works for me using build 1999-10-24-09-M11 on Windows 98 SE.
(Assignee)

Updated

18 years ago
Assignee: peterl → pierre
(Assignee)

Comment 2

18 years ago
Reassigning peterl's bugs to myself
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Summary: xml files don't display
(Assignee)

Comment 3

18 years ago
The entire document is displayed in Courier 9pt and navy color, exactly as it is
supposed to be, because of the following CSS declaration which applies to all the
lines of your xml file:
    para {
      font-family: Courier;
      font-size: 9pt;
      color: navy;
    }

I'm closing this bug as Invalid but if you feel that I'm in error, feel free to
reopen. In that case, please describe more accurately the kind of result you get,
what you expected and if possible attach some screen snapshots to the bug report
(click on "Create a new attachment").

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Using 10/27 Apprunner on  Win 95, page renders properly with css styles.
Verified invalid.
You need to log in before you can comment on or make changes to this bug.