Closed Bug 1726144 Opened 11 months ago Closed 9 months ago

Word "Playing..." on the tab messes up window sizes

Categories

(Firefox :: Tabbed Browser, defect)

Desktop
Unspecified
defect

Tracking

()

RESOLVED DUPLICATE of bug 1714276

People

(Reporter: andreypz, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Open a page where an audio is playing.

  • try on youtube.com:
    Start the video, than pause it for a few seconds. Then unpause it.
  • even better, try on lichess.org and try to play a game of chess, expanding enlarging a board a bit

Actual results:

Word "Playing" appears under the tab title.
When you hit pause the word disappears and the whole video jumps up a bit.
When unpaused, it jumps again
This is very annoying, but tolerable on youtube. On lichess.com it's impossible to tolerate because the chess boards is shrinking and expanding
It is mos

Expected results:

The height of the tab should not change when audio is playing (word playing should fit in the existing height of the tab's title).
Alternatevely, there should be an option to disable that behaviour. In fact in previous version it was possible to disable switching of "proton". In version 91.0 this does not work.

The Bugbug bot thinks this bug should belong to the 'Core::Audio/Video: Playback' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

I believe this is a UI-related issue rather than an audio/video issue.

Component: Audio/Video: Playback → Tabbed Browser
Product: Core → Firefox
Hardware: Unspecified → Desktop
Version: Firefox 91 → unspecified

Could you try to reproduce this issue with a new profile? Here is a link on how to create a new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles
Would you mind checking latest nightly version of firefox as well? Here is a link from where you can download it: https://www.mozilla.org/en-US/firefox/channel/desktop/

Hi Clara,

Another useful piece of information: I am running Firefox on Ubuntu, particularly:
Ubuntu 20.04.3 LTS

I hope someone could test it on Ubuntu on your team, and fix this asap.

See Also: → 1729216

It looks like in 92.0 the bug is kind of solved.
The "Playing" word still shoes up, but the tab size does not change. That's good enough for me, thanks.

Hi ,

Thanks for confirming this issue has been solved on your end.
I’ll mark this ticket as resolved. Please feel free to reopen this bug if you have any troubles.

Regards, Clara

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
Attached image FF-PlayingSizeBug.jpg

I don't know if simply adding a comment reopens a bug or some other procedure is required,
but for me, on Firefox 92.0.1 (64 bit) on Windows 10 - the behavior is NOT changed at all.

Here is a barebones test case:
http://acrozilla.com/test1/soundtest.html
(Use https if you prefer that.)

Open the page in a window all by itself (but for sure with no other sounds playing).
Open the Web Developers Tools -> console.

Click the "Play Sound" button.

What happens is:
a ticking sound plays, and at that time "PLAYING" appears and the window resizes to 2 pixels less in height.
It plays for a few seconds, and after a short delay, "PLAYING" goes away and the window resizes back to
its original size. The size changes are logged to the Developer's console.

If you watch carefully, you can see the contets of the window move.
It is even more effective if you put two copies side by side exactly lined up.
As in the above picture, FF-PlayingSizeBug.jpg - view in large format to see that the lines on the right are 2 pixels lower.
(2 pixels is not a lot, but it is noticeable in a "busy" window.)

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Status: REOPENED → RESOLVED
Closed: 9 months ago9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1714276

@andreypz wrote:

Another useful piece of information: I am running Firefox on Ubuntu, particularly:
Ubuntu 20.04.3 LTS

Which desktop environment are you using?
I reported https://bugzilla.mozilla.org/show_bug.cgi?id=1714276 which looks similar and which is linked. For me the bug happens at least with xfce-4.12 (xubuntu-18.04.6).

You need to log in before you can comment on or make changes to this bug.