pop-up windows have old mozilla throbber instead of new phoenix one

VERIFIED FIXED

Status

()

--
trivial
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: dueydotnet, Assigned: hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021001 Phoenix/0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021001 Phoenix/0.2

In that message forum, clicking on a link brings up the thread in a popup
window.    The throbber that the pop-up window uses appears to be the old
Mozilla throbber.  Defintely not the new one Phoenix uses.

Reproducible: Always

Steps to Reproduce:
1. Go to web site indicated.
2. Click on a thread link.
3. Watch the throbber in the new pop-up window.

Actual Results:  
Shows old throbber in the pop-up window.

Expected Results:  
Show new Phoenix throbber in pop-up window.

Comment 1

16 years ago
Confirmed. We need to not ship that old throbber. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
I can't verify this bug with the given testcase. No pop-up window comes up, even
after explicitly allowing all pop-up windows. I don't see this issue with other
pop-up windows either. Can anybody give a better testcase? It's also possible
that this issue has been resolved with the themechange over to Qute.

Comment 3

16 years ago
This bug is fixed. Thanks, Simon.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
REOPENED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6

This is not fix.  I have the following preference on that might be related to
this bug.
dom.disable_window_open_feature.menubar set to true
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 5

15 years ago
Created attachment 128568 [details]
A link shows a popup with ony a location bar

I attached a test case. Javascript is used to open a popup with only a location
bar, and lo and behold the old throbber shows up.

Confirmed.

Comment 6

15 years ago
communicator/brand/throbber16-single.gif
communicator/brand/throbber16-anim.gif

these are the throbber files that get used in this case.  but the weird thing is
that they get used even if there are no references to them in the theme css. 
they are referenced in communicator/brand.css, but even if that file doesn't
exist, they get used.  so i have no idea where it picks them up from.  if those
image files don't exist (some themes don't have them) an empty box is drawn. 
also kinda weird - it always uses the small 16px size throbber, even if you have
large icons on.  there's some direct reference to the above file names.

a cheap fix - copy and rename the default (new) throbbers
browser/Throbber-small.png
browser/Throbber-small.gif
to
communicator/brand/throbber16-single.gif
communicator/brand/throbber16-anim.gif

Comment 7

15 years ago
few more things:
tested this with various themes on 0.6 milestone, 20030611 nightly, and 6.1rc
(2003-07-25-1.5a).  running Windows 2000

also, it only shows up if the throbber is placed on the nav bar.  so users with
the default button set on the recent nightlies (throbber on the menubar), or
users who put it on other toolbars might not see this.

Comment 8

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Comment 9

15 years ago
*** Bug 205531 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Created attachment 129757 [details] [diff] [review]
throbber hack

This patch takes care of this problem for me using the default theme.  Some
themes don't use the throbber-small.png and throbber-small.gif file names like
the default and so you will get varied results with different themes.  Not sure
if that's a theme problem or something else.  
BTW, this is my first patch (chose a simple one first, I think! <g>), so
hopefully I've done everything correctly.
(Assignee)

Comment 11

15 years ago
Fixed.  I just yanked the rules.  
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.