Closed Bug 1726183 Opened 2 years ago Closed 4 months ago

[XFA] Buttons have no focus indicator when navigating by keyboard

Categories

(Firefox :: PDF Viewer, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- disabled
firefox91 --- disabled
firefox92 --- disabled
firefox93 --- wontfix
firefox107 --- verified

People

(Reporter: danibodea, Assigned: calixte)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [access-s2][pdfjs-form-xfa-js][pdfjs-accessibility])

Attachments

(3 files)

Attached file imm5257e.pdf

Note

  • When the user loads some specific PDF files and navigates them by keyboard (Tab key), he will notice that the buttons are not visually highlighted, although focused.

Affected versions

  • Beta v92.0b4

Affected platforms

  • all

Steps to reproduce

  1. Launch browser.
  2. Load the attached PDF file.
  3. Press the Tab key to focus through the form fields to reach some buttons. (the only way to notice that the buttons are being highlighted is to observe that the page jumps up and the buttons are the first thing in view.

Expected result

  • When focusing on the buttons, there should be a clear visual representation of them.

Actual result

  • When focus reaches the "Validate" or "Clear Form" buttons, no clear visual representation is seen.
  • The focus is moved from the PDF controls to a radio button (on page 2, sub-section 6, from PASSPORT section), then to an "Email address" text field (on page 2, sub-section 6, from CONTACT INFORMATION section, then (presumably) focuses the "Validate" and "Clear Form" buttons from the top of the document, only then finally focusing the first field of the document (1. UCI)...

Regression range

  • Not a recent regression, but it is important to notice that a more confusing behavior can be seen in Release v91.0 since a visual highlight was even more lacking (XFA disabled under pref in this channel).

Additional notes

  • I have set this bug's severity as S4 because the functionality of these buttons is not even supported yet. Dynamic elements of XFA forms are covered in meta bug 1717661 (not yet supported).
  • I've set it to block bug 1706133 because the highlight is a matter of navigation.
  • [access] keyword set because it's an interest of keyboard users. Removed it if believed to be correct.
No longer depends on: 1726173
See Also: → 1726173

This issue can also be observed here.
The "Reset form" and "Reset information" buttons/links and the "Visit Assure Dynamics for more solutions | www.assuredynamics.com" link are not visually highlighted when focused. Adobe shows a subtle dotted line when focusing on these elements.

Summary: [XFA] Buttons don't show a visual highlight when navigating by keyboard → [XFA] Buttons have no focus indicator when navigating by keyboard
Whiteboard: [access-s2]
QA Whiteboard: [pdf_xfa_generic]

Given that we don't support using the buttons (they are a dynamic XFA feature) and we don't plan to support them anytime soon, I'll mark this as blocking bug 1717661 instead of bug 1706133.

Blocks: 1717661
No longer blocks: pdf-xfa
Priority: -- → P3
Whiteboard: [access-s2] → [access-s2][pdfjs-form-xfa-js][pdfjs-accessibility]

The severity field for this bug is set to S4. However, the accessibility severity is higher, [access-s2].
:bdahl, could you consider increasing the severity?

For more information, please visit auto_nag documentation.

Flags: needinfo?(bdahl)
Assignee: nobody → cdenizet
Severity: S4 → S2
Priority: P3 → P2
Flags: needinfo?(bdahl)
Attachment #9294672 - Attachment is patch: true
Attachment #9294672 - Attachment is patch: false
Attachment #9294672 - Attachment mime type: text/plain → text/x-github-pull-request
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Flags: qe-verify+

Verified - Fixed in latest Nightly 108.0a1 (2022-10-20) and Beta 107.0b2 using Windows 10, macOS 12 and Ubuntu 20. When focusing on the buttons, there is a visual representation of them.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.