Closed Bug 1726323 Opened 2 months ago Closed 5 days ago

[layout.css.devPixelsPerPx] Random Toolbar menus (Library, Downloads Panel, Application Menu, etc.) won't open

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 91
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1735095
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- disabled
firefox92 --- disabled
firefox93 --- disabled
firefox94 --- disabled

People

(Reporter: jeroen, Unassigned, NeedInfo)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image firefox toolbars.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Open Downloads panel, Library or Application menu form the Toolbar by clicking on the corresponding icons.

Actual results:

From version 90 I noticed that Library or other items in the Toolbar won't open when I click it. Instead it flickers a few times on mouse movement - it looks like it opens but it's not visible, it becomes visible a fraction of a second when I move the mouse otherwise it's completely transparent.

Which Toolbar icon this affects seems random. I tried to fix it by resetting the Toolbar and disabling extensions which have icons in the Toolbar. Then I noticed that Library was working normal again but Downloads or Application Menu wouldn't open.

When this happened with the Application Menu I could barely see the contents of the menu by moving the mouse which made the menu flicker. The cursor was able to select menu items in the menu but it was completely transparent.

In the enclosed screenshot you can see I selected the Library menu item but it isn't opened.

Expected results:

The menus in the Toolbar should open like they used to.

Ubuntu 21.04
Firefox 91

The Bugbug bot thinks this bug should belong to the 'Firefox::Downloads Panel' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Downloads Panel

This was also reported downstream: https://bugs.launchpad.net/firefox/+bug/1940417

Could this be https://bugzilla.mozilla.org/show_bug.cgi?id=1719898 ?

Jeroen, thanks for the report. Can you also observe the problem with upstream builds of firefox (downloaded from https://www.mozilla.org/firefox/download/thanks), or is it specific to the Ubuntu package?

(In reply to Olivier Tilloy from comment #3)

This was also reported downstream: https://bugs.launchpad.net/firefox/+bug/1940417

I checked about:config for gfx.webrender.unaccelerated-widget.force and this is set to false.

(In reply to Olivier Tilloy from comment #4)

Could this be https://bugzilla.mozilla.org/show_bug.cgi?id=1719898 ?

Jeroen, thanks for the report. Can you also observe the problem with upstream builds of firefox (downloaded from https://www.mozilla.org/firefox/download/thanks), or is it specific to the Ubuntu package?

I haven't checked upstream or nightly builds yet, ususally I stay with release updates only.

(In reply to Jeroen from comment #6)

(In reply to Olivier Tilloy from comment #4)

Could this be https://bugzilla.mozilla.org/show_bug.cgi?id=1719898 ?

Jeroen, thanks for the report. Can you also observe the problem with upstream builds of firefox (downloaded from https://www.mozilla.org/firefox/download/thanks), or is it specific to the Ubuntu package?

I haven't checked upstream or nightly builds yet, ususally I stay with release updates only.

I understand you want to stay with release updates only. You can download an upstream release build, unpack it in a temporary folder and run it just for the purpose of testing this one bug. It will by default create a separate profile, so that won't mess with your normal setup. And it would be very useful to confirm whether the bug is indeed an upstream issue, or Ubuntu-specific.

(In reply to Olivier Tilloy from comment #7)

(In reply to Jeroen from comment #6)

(In reply to Olivier Tilloy from comment #4)

Could this be https://bugzilla.mozilla.org/show_bug.cgi?id=1719898 ?

Jeroen, thanks for the report. Can you also observe the problem with upstream builds of firefox (downloaded from https://www.mozilla.org/firefox/download/thanks), or is it specific to the Ubuntu package?

I haven't checked upstream or nightly builds yet, ususally I stay with release updates only.

I understand you want to stay with release updates only. You can download an upstream release build, unpack it in a temporary folder and run it just for the purpose of testing this one bug. It will by default create a separate profile, so that won't mess with your normal setup. And it would be very useful to confirm whether the bug is indeed an upstream issue, or Ubuntu-specific.

I'm not exactly sure how to install a Firefox beta in a separate folder and run it. If you can help me with that, I'd be happy to help.

Maybe this also helps, I think these new reports concern same bug:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1939941
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1939895

(In reply to Jeroen from comment #8)

I'm not exactly sure how to install a Firefox beta in a separate folder and run it. If you can help me with that, I'd be happy to help.

No need for it to be a beta. Just download the upstream build from https://www.mozilla.org/firefox/download/thanks, unpack the compressed archive in a temporary folder, this will create a "firefox" folder in there, and from that folder just run ./firefox.
Once you've tested and reproduced (or not) the bug, you can safely delete that temporary folder.

I figured installing and running a Firefox beta couldn't be that hard so I downloaded firefox-91.0.1.tar.bz2 and ran it from /Downloads/Firefox/

The menus seem to work fine in the 91.0.1 release.

I realized I enabled browser.compactmode.show in about:config, when I reset this setting to false menus seem to open again.

I this case Library menu in Toolbar wouldn't open. It opens now but when I choose Bookmarks or History these menus flicker on mouse move.

This also seems to have been fixed in the 91.0.1 release, even with browser.compactmode.show enabled.

I just noticed that the flickering of the quite long Bookmarks and History menus in the 91 release only occur in Maximized window mode, in Minimized the menus open normally, extending beyond the Firefox window bounds and the bottom of these menus appear to conflict with the Dock (appear under it?). These long menus seem to have been improved in the 91.0.1 release and the bottom of the menus appear on top of the Dock.

Doesn't looks like the bot picked anywhere close to the right component here.

Per the comments, is this just resolved? It sounds like the 91.0.1 dot-release fixed the issues here?

Component: Downloads Panel → Graphics
Flags: needinfo?(jeroen)
Product: Firefox → Core

That sounds suspicious, there's nothing related in the 91.0.1 update release notes.
The bug was reported by Jeroen downstream (Ubuntu) against 91.0 (see https://bugs.launchpad.net/firefox/+bug/1940417), and according to the last few comments here, it's fixed in a 91.0.1 upstream build. However Ubuntu builds run with MOZ_ENABLE_WAYLAND, maybe that makes a difference?

Jeroen, could you please test again the upstream build by running it like this?

MOZ_ENABLE_WAYLAND=1 ./firefox

and let us know whether the issue can be observed there?

Sure. I just type MOZ_ENABLE_WAYLAND=1 ./firefox in terminal?

Flags: needinfo?(jeroen)

Sure. I just type MOZ_ENABLE_WAYLAND=1 ./firefox or add this to about:config?

From the folder where you unpacked the upstream build, type that command in a terminal.

Sorry I'm not used to run apps like that.

Do you mean I should type sudo MOZ_ENABLE_WAYLAND=1 and then [path to application]?

When I type command echo $XDG_SESSION_TYPE returns wayland so I suppose FF already runs in Wayland?

xrandr --listmonitors returns:

Monitors: 1
0: +*XWAYLAND0 1920/508x1080/286+0+0 XWAYLAND0

No, I didn't mention sudo. Just open a terminal and type the following commands, one per line, verbatim:

cd /tmp
wget https://download-installer.cdn.mozilla.net/pub/firefox/releases/91.0.1/linux-x86_64/en-US/firefox-91.0.1.tar.bz2
tar xf firefox-91.0.1.tar.bz2
MOZ_ENABLE_WAYLAND=1 ./firefox/firefox

Alright. Thanks.

When I right click the toolbar and go customize it I can't see the little menu which makes the Download Panel button stay.

Menus seem to open fine though, except when you right click the Toolbar the fly out menu from Bookmarks Toolbar flickers sometimes when moving the mouse. Makes it hard to make a selection.

Do you have a clue whats causing this? Graphics drivers maybe or something in FF?

btw I got these messages in terminal after installing:

Gdk-Message: 20:17:14.812: Unable to load openhand from the cursor theme
Gdk-Message: 20:17:14.812: Unable to load 5aca4d189052212118709018842178c0 from the cursor theme
Gdk-Message: 20:17:19.096: Unable to load closedhand from the cursor theme

I've updated to 91.0.1

Now the Toolbar menus open but now the fly out or next menus flicker.

On mouse movement they flicker rapidly, when there's no mouse movement the menus disappear:

Library > Bookmarks > flickering menu
Library > History > flickering menu

Fly out menus in Application Menu seem to work fine.

Hi,

Is there anything I can do to try and fix this? It is getting quite annoying...

I'd like to add that the list of visited pages and websites, which appears when you hold the Back or Forward button, also flickers on mouse movement. When I do not move the mouse the menu isn't visible at all. Right click on tthis button still works.

Does the flickering happen on a mozilla.org (not distro) Firefox, with a clean separate profile with no other changes (add-ons, prefs changed, etc.)? See this SUMO page for details on how to create a separate profile.

If so, can you provide the graphics portion of the about:support section of such a profile, please?

Flags: needinfo?(jeroen)

I can't speak for Jeroen, but I played around with the upstream builds (both 92 and 91) and my faulty profile a bit and managed to isolate the trigger combination for this: MOZ_ENABLE_WAYLAND=1 and setting layout.css.devPixelsPerPx to my preferred value of 1.2; either resetting layout.css.devPixelsPerPx to its default (-1.0), or running Firefox without MOZ_ENABLE_WAYLAND=1 will make the toolbar items work again. Here's the graphics portion of my about:support.

So my steps to reproduce this are:

  1. start Firefox with MOZ_ENABLE_WAYLAND=1
  2. set layout.css.devPixelsPerPx to 1.2
  3. click on the hamburger menu button

What I expect to happen:
For the hamburger menu content to show.

What happens instead:
The hamburger menu content flickers or doesn't show at all.

Component: Graphics → Widget: Gtk
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

(In reply to Jani Uusitalo from comment #26)

I can't speak for Jeroen, but I played around with the upstream builds (both 92 and 91) and my faulty profile a bit and managed to isolate the trigger combination for this: MOZ_ENABLE_WAYLAND=1 and setting layout.css.devPixelsPerPx to my preferred value of 1.2; either resetting layout.css.devPixelsPerPx to its default (-1.0), or running Firefox without MOZ_ENABLE_WAYLAND=1 will make the toolbar items work again. Here's the graphics portion of my about:support.

So my steps to reproduce this are:

  1. start Firefox with MOZ_ENABLE_WAYLAND=1
  2. set layout.css.devPixelsPerPx to 1.2
  3. click on the hamburger menu button

What I expect to happen:
For the hamburger menu content to show.

What happens instead:
The hamburger menu content flickers or doesn't show at all.

Just for reference/as a workaround: A value of 1.25 for layout.css.devPixelsPerPx seems to work flawlessly for me (I was also using 1.2 :-) ).

In fact, it seems really strange what values for layout.css.devPixelsPerPx trigger this – 1.22 also seems to work without issues, while other values (like 1.21) don’t.

(In reply to simon.may from comment #28)

In fact, it seems really strange what values for layout.css.devPixelsPerPx trigger this – 1.22 also seems to work without issues, while other values (like 1.21) don’t.

Sorry, nevermind, 1.22 does have problems with some entries in the bookmarks toolbar.

Please test with latest nightly, how-to is here:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Testing_Mozilla_binaries

You should create a new profile so it won't break your working Firefox setup.

Alternatively you can use mozregression tool:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Use_Mozregression_tool

as:

MOZ_ENABLE_WAYLAND=1 mozregression --good 91.0

and it will download and launch nightly for you but you need to check which version is actually running (mozregression will download and launch Firefox 91, Nightly and versions between these two).

Priority: -- → P3

I ran mozregression like this (twice, to be sure):

MOZ_ENABLE_WAYLAND=1 mozregression --profile /home/jani/.mozilla/firefox/fyaus28k.LP1940417 --bad 91 --good 89 --profile-persistence clone-first

Here's the result (it was the same for both bisects):

5:25.73 INFO: No more integration revisions, bisection finished.
5:25.73 INFO: Last good revision: 9f0fbb1431721c9eae68a3c94ae49a4d33fdb1f8
5:25.73 INFO: First bad revision: 7b82d177a6b979036f180329be6b029d690d9e0c
5:25.73 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9f0fbb1431721c9eae68a3c94ae49a4d33fdb1f8&tochange=7b82d177a6b979036f180329be6b029d690d9e0c

According to that log, this changeset was introduced to address #1661516.

Also, I tested the 94.0a1 nightly now, and the issue is still present.

Ubuntu and Fedora ship an untested pre-Nightly feature. (MOZ_ENABLE_WAYLAND = bug 1543600)

Summary: Random Toolbar menus (Library, Downloads Panel, Application Menu, etc.) won't open → [layout.css.devPixelsPerPx] Random Toolbar menus (Library, Downloads Panel, Application Menu, etc.) won't open

Can you test latest nightly please? Might be fixed by Bug 1735095.
Thanks.

I tested 95.0a1 (Nightly), and opening the hamburger menu (using the steps I outlined above) works now.

Closing it is still partly broken though, as clicking on the menu button doesn't close the menu; I think that is bug 1694514.

For a workaround, clicking outside the menu (and the menu button) does close the menu.

(In reply to Jani Uusitalo from comment #35)

Closing it is still partly broken though, as clicking on the menu button doesn't close the menu; I think that is bug 1694514.

For a workaround, clicking outside the menu (and the menu button) does close the menu.

Yes, that's a different bug.

Status: UNCONFIRMED → RESOLVED
Closed: 5 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1735095
You need to log in before you can comment on or make changes to this bug.