Closed Bug 1726493 Opened 1 year ago Closed 1 year ago

Mailing list changes could (theoretically) happen on a read-only directory

Categories

(MailNews Core :: Address Book, defect)

defect

Tracking

(thunderbird_esr91+ fixed)

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr91 + fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

If a directory is marked as read-only, any mailing lists inside it should also be read-only. We're not actually checking though.

I guess it solves issues behind bug 1717694.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0a823ac3de81
Check read-only status of a mailing list's directory before changes. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Blocks: tb91found

Comment on attachment 9236947 [details]
Bug 1726493 - Check read-only status of a mailing list's directory before changes. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: mailing lists could be modified even if the owning address book is read-only
Testing completed (on c-c, etc.): in 93.0b1
Risk to taking this patch (and alternatives if risky): no

Attachment #9236947 - Flags: approval-comm-esr91?

Comment on attachment 9236947 [details]
Bug 1726493 - Check read-only status of a mailing list's directory before changes. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9236947 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.