Closed Bug 1726537 Opened 4 months ago Closed 3 months ago

Unexpected extra folder created when downloading files

Categories

(Firefox :: Downloads Panel, defect)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox91 --- unaffected
firefox92 --- unaffected
firefox93 --- verified

People

(Reporter: jryans, Assigned: ava8katushka)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Set download preferences to store downloads in your home directory's Downloads folder
    • More precisely, in my case, it means prefs have the following values:
      • browser.download.dir: /Users/jryans/Downloads
      • browser.download.folderList: 1
      • browser.download.improvements_to_download_panel: false
  2. Download a file, such as VS Code by going to https://code.visualstudio.com/Download and clicking some download button on the page

ER:

The downloaded file should appear in ~/Downloads.

AR:

While the downloaded file does appear in the right place... a extra folder named mozilla_jryans0 is also created in ~/Downloads. Sometimes, the downloaded files seem to end up inside that extra folder, and sometimes they go to the expected location directly.

mozregression confirms this is connected to bug 1714107:

14:25.88 INFO: Last good revision: 675fd489778c50f4cf03faed0254f5be867af850
14:25.88 INFO: First bad revision: 3e4876dd46ecdc58e221f52334bdba08bd4251a2
14:25.88 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=675fd489778c50f4cf03faed0254f5be867af850&tochange=3e4876dd46ecdc58e221f52334bdba08bd4251a2
Hardware: Unspecified → Desktop

Before bug 1714107, the extra path was appended only if !XP_MACOSX && !ANDROID && !XP_WIN && !XP_UNIX && XP_UNIX. In other words, it was a dead code. Node that the last # if defined(XP_UNIX) was enclosed in the #else block before the patch:
https://hg.mozilla.org/integration/autoland/rev/3e4876dd46ecdc58e221f52334bdba08bd4251a2#l1.139

Bug 1714107 erroneously enabled the dead code on all platforms. We should have removed this dead code here:
https://searchfox.org/mozilla-central/rev/9dceacf3d761eb91237108ec438d64099a56f442/uriloader/exthandler/nsExternalHelperAppService.cpp#355-423

Assignee: nobody → ava8katushka
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/dc8c1d212207
Delete dead code creating extra path in downloads. r=emk
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

On second thought, I think the removed code is still required (with some modifications to prevent this bug). See bug 1726732.

Flags: qe-verify+

Hello! I tried to verify the issue on macOS 10.15 but unfortunately, I cannot reproduce the issue with Firefox 93.0a1 (2021-08-19). As stated in comment 1 the STR I followed was:

  1. Set:
    browser.download.dir: /Users/svuser/Downloads
    browser.download.folderList: 1
    browser.download.improvements_to_download_panel: false
  2. Go to https://code.visualstudio.com/Download and click on download for macOS version. For me at least there no extra folder created and the file is downloaded inside the Downloads folder as expected.

Can you please verify if I'm doing something wrong on my end or verify if this is fixed with the latest beta? Thank you!

Flags: needinfo?(jryans)

This bug depends on the operating system. macOS is not affected. You will have to use Linux to reproduce the issue.

Passing needinfo back per comment #7.

Flags: needinfo?(jryans) → needinfo?(alexandru.trif)
Attached image bug1726537.gif

Thank you both for your answers. Unfortunately, I still can't reproduce the issue with 93.0a1 (2021-08-18) on Ubuntu 18. Am I doing something wrong? Attached a screen recording as well. Thank you!

Flags: needinfo?(alexandru.trif)

(In reply to Alexandru Trif, QA [:atrif] [PTO until 15Oct] from comment #6)

Hello! I tried to verify the issue on macOS 10.15 but unfortunately, I cannot reproduce the issue with Firefox 93.0a1 (2021-08-19). As stated in comment 1 the STR I followed was:

  1. Set:
    browser.download.dir: /Users/svuser/Downloads
    browser.download.folderList: 1
    browser.download.improvements_to_download_panel: false
  2. Go to https://code.visualstudio.com/Download and click on download for macOS version. For me at least there no extra folder created and the file is downloaded inside the Downloads folder as expected.

Can you please verify if I'm doing something wrong on my end or verify if this is fixed with the latest beta? Thank you!

In Nightly 93.0a1 (2021-08-18) for macOS, I can confirm the issue was present using the same settings you list above. If you use a clean profile, that also reproduces as well.

In Beta 93.0 for macOS, the issue is fixed, so I believe we can consider this verified.

(In reply to Masatoshi Kimura [:emk] from comment #7)

This bug depends on the operating system. macOS is not affected. You will have to use Linux to reproduce the issue.

Hmm, I am confused by this comment, since I originally reported this bug about macOS... I guess bug 1726732 made further changes for non-macOS Unix systems (e.g. Linux), but that's perhaps separate from verifying the fix over here.

Status: RESOLVED → VERIFIED
Flags: needinfo?(alexandru.trif)

(In reply to J. Ryan Stinnett [:jryans] (Use needinfo, replies may be slow) from comment #10)

(In reply to Alexandru Trif, QA [:atrif] [PTO until 15Oct] from comment #6)

Hello! I tried to verify the issue on macOS 10.15 but unfortunately, I cannot reproduce the issue with Firefox 93.0a1 (2021-08-19). As stated in comment 1 the STR I followed was:

  1. Set:
    browser.download.dir: /Users/svuser/Downloads
    browser.download.folderList: 1
    browser.download.improvements_to_download_panel: false
  2. Go to https://code.visualstudio.com/Download and click on download for macOS version. For me at least there no extra folder created and the file is downloaded inside the Downloads folder as expected.

Can you please verify if I'm doing something wrong on my end or verify if this is fixed with the latest beta? Thank you!

In Nightly 93.0a1 (2021-08-18) for macOS, I can confirm the issue was present using the same settings you list above. If you use a clean profile, that also reproduces as well.

In Beta 93.0 for macOS, the issue is fixed, so I believe we can consider this verified.

Thank you for verifying. Updating flags based on comment 10.

Flags: qe-verify+
Flags: needinfo?(alexandru.trif)
You need to log in before you can comment on or make changes to this bug.