Closed Bug 1726623 Opened 4 months ago Closed 3 months ago

reviewbot's source-test-clang-format task fails with "ERROR: Cannot find a wasi sysroot"

Categories

(Firefox Build System :: Source Code Analysis, defect)

Firefox 93
defect

Tracking

(firefox93 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: bytesized, Assigned: andi)

References

Details

Attachments

(1 file)

Phabricator URL: https://phabricator.services.mozilla.com/...

Huh. I'm not sure why it pre-populated the phabricator URL like that. Here's the relevant Phabricator URL.

Review bot seems to be having some sort of problem with its source-test-clang-format task. Every time it runs it on this revision, it tells me:

The analysis task source-test-clang-format failed, but we could not detect any issue.

When I look at the log file for that task, it appears to have failed during the configure stage with

ERROR: Cannot find a wasi sysroot. Please give its location with --with-wasi-sysroot.

This error doesn't seem relevant to the patch I'm writing, so I'm not sure what other information would be useful for me to provide.

Andi, do you want to add the wasi sysroot or to remove the need for configure?

Flags: needinfo?(bpostelnicu)
Assignee: nobody → bpostelnicu
Status: NEW → ASSIGNED
Flags: needinfo?(bpostelnicu)
Duplicate of this bug: 1727412
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
You need to log in before you can comment on or make changes to this bug.