Closed Bug 1726838 Opened 4 months ago Closed 3 months ago

Intermittent toolkit/components/nimbus/test/browser/browser_experimentstore_load.js | Uncaught exception - Stub was called - timed out after 50 tries.

Categories

(Firefox :: Nimbus Desktop Client, defect, P5)

defect

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: andreio)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: mlaza [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=349057098&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/EXemxcFuTqa9empDVXD27g/runs/0/artifacts/public/logs/live_backing.log


[task 2021-08-20T18:39:26.552Z] 18:39:26     INFO - TEST-START | toolkit/components/nimbus/test/browser/browser_experimentstore_load.js
[task 2021-08-20T18:39:26.612Z] 18:39:26     INFO - GECKO(3151) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /var/folders/41/0wfbzkvj4dlf_qqdn_pr3g_h000014/T/tmph3tkomjq.mozrunner/runtests_leaks_tab_pid3156.log
[task 2021-08-20T18:39:26.613Z] 18:39:26     INFO - GECKO(3151) | [3156, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp:248
[task 2021-08-20T18:39:31.952Z] 18:39:31     INFO - GECKO(3151) | [Child 3153, Main Thread] WARNING: Shouldn't call SchedulePaint in a detached pres context: file /builds/worker/checkouts/gecko/layout/generic/nsIFrame.cpp:7184
[task 2021-08-20T18:39:31.952Z] 18:39:31     INFO - GECKO(3151) | [Child 3153, Main Thread] WARNING: Shouldn't call SchedulePaint in a detached pres context: file /builds/worker/checkouts/gecko/layout/generic/nsIFrame.cpp:7184
[task 2021-08-20T18:39:31.964Z] 18:39:31     INFO - GECKO(3151) | [Child 3154, Main Thread] WARNING: '!aContent->GetComposedDoc()', file /builds/worker/checkouts/gecko/layout/base/nsCSSFrameConstructor.cpp:8602
[task 2021-08-20T18:39:31.965Z] 18:39:31     INFO - GECKO(3151) | [Child 3154, Main Thread] WARNING: '!aContent->GetComposedDoc()', file /builds/worker/checkouts/gecko/layout/base/nsCSSFrameConstructor.cpp:8602
[task 2021-08-20T18:39:31.965Z] 18:39:31     INFO - GECKO(3151) | [Child 3154, Main Thread] WARNING: '!aContent->GetComposedDoc()', file /builds/worker/checkouts/gecko/layout/base/nsCSSFrameConstructor.cpp:8602
[task 2021-08-20T18:39:31.966Z] 18:39:31     INFO - GECKO(3151) | [Child 3154, Main Thread] WARNING: '!aContent->GetComposedDoc()', file /builds/worker/checkouts/gecko/layout/base/nsCSSFrameConstructor.cpp:8602
[task 2021-08-20T18:39:32.881Z] 18:39:32     INFO - GECKO(3151) | [Child 3153: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 110f1ec00 == 1 [pid = 3153] [id = 0] [url = about:blank]
[task 2021-08-20T18:39:35.806Z] 18:39:35     INFO - TEST-INFO | started process screencapture
[task 2021-08-20T18:39:35.920Z] 18:39:35     INFO - TEST-INFO | screencapture: exit 0
[task 2021-08-20T18:39:35.920Z] 18:39:35     INFO - Buffered messages logged at 18:39:26
[task 2021-08-20T18:39:35.921Z] 18:39:35     INFO - Entering test bound setup
[task 2021-08-20T18:39:35.921Z] 18:39:35     INFO - Leaving test bound setup
[task 2021-08-20T18:39:35.922Z] 18:39:35     INFO - Entering test bound test_loadFromFile
[task 2021-08-20T18:39:35.922Z] 18:39:35     INFO - TEST-PASS | toolkit/components/nimbus/test/browser/browser_experimentstore_load.js | This should pass if the correct store path loaded successfully - true == true - 
[task 2021-08-20T18:39:35.923Z] 18:39:35     INFO - Leaving test bound test_loadFromFile
[task 2021-08-20T18:39:35.923Z] 18:39:35     INFO - Entering test bound test_load_from_disk_event
[task 2021-08-20T18:39:35.923Z] 18:39:35     INFO - Buffered messages finished
[task 2021-08-20T18:39:35.924Z] 18:39:35     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/nimbus/test/browser/browser_experimentstore_load.js | Uncaught exception - Stub was called - timed out after 50 tries.
[task 2021-08-20T18:39:35.924Z] 18:39:35     INFO - Leaving test bound test_load_from_disk_event
[task 2021-08-20T18:39:35.925Z] 18:39:35     INFO - GECKO(3151) | MEMORY STAT | vsize 7894MB | residentFast 325MB | heapAllocated 117MB
[task 2021-08-20T18:39:35.925Z] 18:39:35     INFO - TEST-OK | toolkit/components/nimbus/test/browser/browser_experimentstore_load.js | took 9261ms
[task 2021-08-20T18:39:35.926Z] 18:39:35     INFO - GECKO(3151) | [Child 3155: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 10f702c00 == 2 [pid = 3155] [id = 1]
[task 2021-08-20T18:39:35.926Z] 18:39:35     INFO - GECKO(3151) | [Child 3155: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 3 (10f5df040) [pid = 3155] [serial = 3] [outer = 0]
[task 2021-08-20T18:39:35.927Z] 18:39:35     INFO - GECKO(3151) | [Child 3155: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 4 (10f703c00) [pid = 3155] [serial = 4] [outer = 10f5df040]
[task 2021-08-20T18:39:35.927Z] 18:39:35     INFO - checking window state
[task 2021-08-20T18:39:35.928Z] 18:39:35     INFO - TEST-START | toolkit/components/nimbus/test/browser/browser_nimbus_telemetry.js
Assignee: nobody → andrei.br92
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/82452705d800
Intermittent toolkit/components/nimbus/test/browser/browser_experimentstore_load.js r=k88hudson
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Duplicate of this bug: 1727085
You need to log in before you can comment on or make changes to this bug.