Closed Bug 1726894 Opened 1 year ago Closed 3 months ago

Wayland: Message header's "More" menu flickering at cursor move

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 91
Unspecified
Linux
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: asterix52, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

select a message an press the more menu.

Actual results:

menu flickering (redraw of the date and time from the message?). No highlight of a menu entry.

Expected results:

no flicker and highlight of the current menu entry

I use Ubuntu 21.10 impish with wayland

Blocks: tb91found
Component: Untriaged → Mail Window Front End
OS: Unspecified → Linux

(In reply to asterix52 from comment #1)

I use Ubuntu 21.10 impish with wayland

Thanks for being a pioneer.

Ubuntu 21.10 isn't scheduled for release until Oct. 14, 2021, Ubuntu 21.10 Beta: Sept 23, 2021, so you are using a daily test build?

Flags: needinfo?(asterix52)

It is the same with troubleshoot mode.

yes. it is the daily build. All proposed updates installed.

Flags: needinfo?(asterix52)

Could it be an Ubuntu 21.10 issue?

It works fine with xorg.

Sounds like a Wayland issue, and 21.10 probably won't be released with Thunderbird 91.0, since Thunderbird will be releasing version 78.15 on or around 10-05, with the update to 91.3 around 11-02.

I can't test Wayland as I have Nvidia graphics and Fedora 34 Workstation, Gnome desktop.

Maybe when the 21.10 beta is available, I'll test with a Live USB and see if I can reproduce.

asterix52, what about Firefox, do the menus flicker too?

Firefox work without any flickering.

In thunderbird 91 only the "more" menu is flickering.

Summary: more menu flickering at cursor move → Message header's "More" menu flickering at cursor move

Troubleshoot mode --> Reset Toolbars and controls

That solved the Problem.

That's wired. Now I have it on the preferences menu (yellow in the message).

Summary: Message header's "More" menu flickering at cursor move → Wayland: Message header's "More" menu flickering at cursor move

I have no issue with 91.0.3

Great, let's close then.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Unfortunately, the problem still exists here with 91.3.1 on Ubuntu 21.10 under Wayland. Menus flickering like shown above. Also the following menus under the main toolbar are affected by the bug: "View", "Message", "Events and Tasks". But others like "File", "Edit", "Go" working normally. Under Xorg everything works fine.

Thunderbird 91.5.1 on Ubuntu daily 22.04 jammy is still flickering (wayland).

Please reopen the bug.

I noticed this behaver:

menu fly out to the left --> flickering
If I make the thunderbird window smaller --> menu fly out to the right --> no flickering
It also flickers more often with events (F11) open

I'm on 'Ubuntu 22.04' (gnome) with Thunderbird 91.5.1.

The flickering menus occur when the text scaling is too high.
Did you activate 'Settings >> Accessibility >> Large Text' in Ubuntu ?

In Terminal you can get the current value with…

gsettings get org.gnome.desktop.interface text-scaling-factor

and set the value for example with…

gsettings set org.gnome.desktop.interface text-scaling-factor 1.24

For me, the 'flickering menus' occur when I set the value to 1.25, which is exactly the value that Ubuntu or Gnome sets with 'Large Text'.
All values below work well. (In reply to asterix52 from comment #19)

I noticed this behaver:

menu fly out to the left --> flickering
If I make the thunderbird window smaller --> menu fly out to the right --> no flickering
It also flickers more often with events (F11) open

(In reply to Gre0 from comment #20)

For me, the 'flickering menus' occur when I set the value to 1.25, which is exactly the value that Ubuntu or Gnome sets with 'Large Text'.
All values below work well.

I can confirm that.

Status: RESOLVED → VERIFIED

(In reply to Gre0 from comment #20)

I'm on 'Ubuntu 22.04' (gnome) with Thunderbird 91.5.1.

The flickering menus occur when the text scaling is too high.
Did you activate 'Settings >> Accessibility >> Large Text' in Ubuntu ?

In Terminal you can get the current value with…

gsettings get org.gnome.desktop.interface text-scaling-factor

and set the value for example with…

gsettings set org.gnome.desktop.interface text-scaling-factor 1.24

For me, the 'flickering menus' occur when I set the value to 1.25, which is exactly the value that Ubuntu or Gnome sets with 'Large Text'.
All values below work well. (In reply to asterix52 from comment #19)

I noticed this behaver:

menu fly out to the left --> flickering
If I make the thunderbird window smaller --> menu fly out to the right --> no flickering
It also flickers more often with events (F11) open

I can confirm, that the text-scaling-factor triggers the bug. Here everything above 1.0 is triggering it. (Which to me makes more sense than an arbitrary number like 1.25).

(In reply to Jürgen Fuchsberger from comment #22)

(In reply to Gre0 from comment #20)

I'm on 'Ubuntu 22.04' (gnome) with Thunderbird 91.5.1.

The flickering menus occur when the text scaling is too high.
Did you activate 'Settings >> Accessibility >> Large Text' in Ubuntu ?

In Terminal you can get the current value with…

gsettings get org.gnome.desktop.interface text-scaling-factor

and set the value for example with…

gsettings set org.gnome.desktop.interface text-scaling-factor 1.24

For me, the 'flickering menus' occur when I set the value to 1.25, which is exactly the value that Ubuntu or Gnome sets with 'Large Text'.
All values below work well. (In reply to asterix52 from comment #19)

I noticed this behaver:

menu fly out to the left --> flickering
If I make the thunderbird window smaller --> menu fly out to the right --> no flickering
It also flickers more often with events (F11) open

I can confirm, that the text-scaling-factor triggers the bug. Here everything above 1.0 is triggering it. (Which to me makes more sense than an arbitrary number like 1.25).

The problem is, if someone (like me) needs a larger font, he opens the system settings (gnome-control-center) and activates the switch for 'Larger font' under 'Accessibility'. This function then simply sets the scaling factor to the value 1.25 for the whole system and this causes the bug in Thunderbird which makes it unusable.
By default, there is no way to select a different value if you want to have a larger font throughout the system.
If you want to do that, you have to install either gnome-tweaks or dconf-editor. Or you have to choose a value in the terminal using the above commands in comment 20.

Maybe all of this also depends on the monitor size, resolution and/or font.
(Here: 46" 1920x1080, Standard-font 'Ubuntu 11')

Must I clone this bug to reopen it?

Status: VERIFIED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Duplicate of this bug: 1744820

Should we report this upstream (firefox)?

My TB has been suffering from that flickering for months and the last update to 91.8.1 did not help.
However, I just noticed that the flickering disappeared after I changed the value of layout.css.devPixelsPerPx in the config editor.
The purpose of that config is to scale the UI font which is slightly too large by default on my laptop.
Until now, I was using 0.8 so I tried slightly different values. There does not appear to be any obvious pattern

0.75 ok
0.76 flicker
0.77 flicker
0.79 flicker
0.795 ok
0.80 flicker
0.81 ok
0.8125 flicker
0.82 ok
0.90 flicker
1.00 ok
1.10 flicker

It should be noted that flickering is not consistent over all menus. For example, my Help menu flickers with 0.76 but not with 0.77. So I suspect that this font scaling is causing an inconsistency during the rendering of the text. Typically, that could be that the predicted size of the output text does not match the size of the actual rendering thus causing a reallocation of the graphic buffer (and so flickering).

I tried thunderbird 102.0a1. I can't notice any flickering . And there is a new menu item (view/font size). This let you adjust the font size of the tree view (great).

Is there a alpha with lightning?

Regards
Norbert

There is no lightning anymore. It's been integrated completely since tb 78.

Status: REOPENED → RESOLVED
Closed: 1 year ago3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.