Closed Bug 1727198 Opened 3 months ago Closed 3 months ago

Firefox crashes when mousing over video link

Categories

(Core :: Graphics, defect)

Firefox 91
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1726807

People

(Reporter: mynamewastaken, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Browsed to https://www.amazon.com/COOLAPA-Four-Head-Spectrum-Adjustable-Gooseneck/dp/B08ZCMQBBG , moused over video link. I can't link to the exact video, as my browser closes.

System info:
[System]
OS: Fedora 34
Arch: x86_64
Kernel: 5.13.12-200.fc34.x86_64
Desktop: GNOME
Display Server: wayland

[CPU]
Vendor: AuthenticAMD
Model: AMD Ryzen 7 3700X 8-Core Processor
Physical cores: 8
Logical cores: 16

[Memory]
RAM: 15.5 GB
Swap: 12.0 GB

[Graphics]
Vendor: AMD
OpenGL Renderer: Radeon RX 580 Series (POLARIS10, DRM 3.41.0, 5.13.12-200.fc34.x86_64, LLVM 12.0.1)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.3.0-devel
OpenGL Core: 4.6 (Core Profile) Mesa 21.3.0-devel
OpenGL ES: OpenGL ES 3.2 Mesa 21.3.0-devel
Vulkan: Supported

Actual results:

Browser closed (crashed?) with following journalctl log:

Aug 23 17:11:04 tim-desktop firefox.desktop[16045]: libva info: VA-API version 1.11.0
Aug 23 17:11:04 tim-desktop firefox.desktop[16045]: libva info: Trying to open /usr/lib64/dri/radeonsi_drv_video.so
Aug 23 17:11:04 tim-desktop firefox.desktop[16045]: libva info: Found init function __vaDriverInit_1_11
Aug 23 17:11:04 tim-desktop firefox.desktop[16045]: libva info: va_openDriver() returns 0
Aug 23 17:11:16 tim-desktop firefox.desktop[16045]: mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
Aug 23 17:11:16 tim-desktop firefox.desktop[16045]: mesa: for the --global-isel-abort option: may only occur zero or one times!
Aug 23 17:11:16 tim-desktop firefox.desktop[16045]: mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
Aug 23 17:11:55 tim-desktop firefox.desktop[16045]: libva info: VA-API version 1.11.0
Aug 23 17:11:55 tim-desktop firefox.desktop[16045]: libva info: Trying to open /usr/lib64/dri/radeonsi_drv_video.so
Aug 23 17:11:55 tim-desktop firefox.desktop[16045]: libva info: Found init function __vaDriverInit_1_11
Aug 23 17:11:55 tim-desktop firefox.desktop[16045]: libva info: va_openDriver() returns 0
Aug 23 17:11:55 tim-desktop gnome-shell[10511]: WL: error in client communication (pid 11582)
Aug 23 17:11:55 tim-desktop firefox[11582]: Error 71 (Protocol error) dispatching to Wayland display.
Aug 23 17:11:55 tim-desktop firefox.desktop[15763]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[41093]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[12012]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[16045]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[12236]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[39793]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[11950]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[11829]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[11790]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop firefox.desktop[11802]: Exiting due to channel error.
Aug 23 17:11:55 tim-desktop systemd[3557]: app-gnome-firefox-11582.scope: Consumed 40min 41.656s CPU time.
Aug 23 17:11:55 tim-desktop systemd[3557]: Stopping cgroupify@app-gnome-firefox-11582.scope.service...
Aug 23 17:11:55 tim-desktop systemd[3557]: Stopped cgroupify@app-gnome-firefox-11582.scope.service.
Aug 23 17:11:55 tim-desktop systemd[3557]: cgroupify@app-gnome-firefox-11582.scope.service: Consumed 6.660s CPU time.

Expected results:

Video played, or at least, browser didn't close.

The Bugbug bot thinks this bug should belong to the 'Core::Graphics' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Graphics
Product: Firefox → Core

Can you goto about:crashes and share the crash stats link for crashes you get from this?

Flags: needinfo?(mynamewastaken)

(In reply to Timothy Nikkel (:tnikkel) from comment #2)

Can you goto about:crashes and share the crash stats link for crashes you get from this?

I don't believe it created an entry there - I only see one and it's from several days ago.

Flags: needinfo?(mynamewastaken)
Flags: needinfo?(mynamewastaken)

Please open about:support, click on "Copy text to clipboard" and paste it here. Thanks!

Attached file about:support paste

Crash Reports for the Last 3 Days

Report ID: bp-7a88f293-8f3d-4e18-afcd-c2f300210824
Submitted: 11 hours ago

Please note that this crash report is not related to this ticket -- it occurred several days earlier.

Flags: needinfo?(mynamewastaken)

(In reply to Andre Klapper from comment #4)

We need a stacktrace or crash ID. See https://support.mozilla.org/en-US/kb/troubleshoot-firefox-crashes-closing-or-quitting

Is there an easy way to force a stacktrace/crash report? I don't have a relevant entry listed in about:crashes .

Thanks!

Aug 23 17:11:55 tim-desktop gnome-shell[10511]: WL: error in client communication (pid 11582)
Aug 23 17:11:55 tim-desktop firefox[11582]: Error 71 (Protocol error) dispatching to Wayland display.

Version: 91.0

Window Protocol: wayland

WEBRENDER_COMPOSITOR:
disabled by default: Disabled by default
force_enabled by user: Force enabled by pref
blocklisted by env: Blocklisted by gfxInfo

media.ffmpeg.vaapi.enabled: true

This could be bug 1726807. Can you confirm that this bug does no longer occur after setting gfx.webrender.compositor and gfx.webrender.compositor.force-enabled to false and restarting Firefox?

General recommendation: If you want to try out these experimental features, please use https://nightly.mozilla.org instead.

(In reply to Darkspirit from comment #8)

Thanks!

Aug 23 17:11:55 tim-desktop gnome-shell[10511]: WL: error in client communication (pid 11582)
Aug 23 17:11:55 tim-desktop firefox[11582]: Error 71 (Protocol error) dispatching to Wayland display.

Version: 91.0

Window Protocol: wayland

WEBRENDER_COMPOSITOR:
disabled by default: Disabled by default
force_enabled by user: Force enabled by pref
blocklisted by env: Blocklisted by gfxInfo

media.ffmpeg.vaapi.enabled: true

This could be bug 1726807. Can you confirm that this bug does no longer occur after setting gfx.webrender.compositor and gfx.webrender.compositor.force-enabled to false and restarting Firefox?

gfx.webrender.compositor was set to false (default it seems), and gfx.webrender.compositor.force-enabled was set to true and I toggled it to false.
The crash does not occur and I'm able to view the video now!

General recommendation: If you want to try out these experimental features, please use https://nightly.mozilla.org instead.

I will look into Nightly; I think I enabled these feature(s) to generally get better scrolling/hardware acceleration/etc. I don't know exactly what all of them do. :-)

Unless you need anything else from me I would say feel free to close the ticket.
Thanks all for your help!

(In reply to mynamewastaken from comment #9)

The crash does not occur and I'm able to view the video now!

Perfect! :)

I will look into Nightly; I think I enabled these feature(s) to generally get better scrolling/hardware acceleration/etc. I don't know exactly what all of them do. :-)

Overview:

  • gfx.webrender.all enforces hardware rendering on the GPU. (bug 1491303)
  • MOZ_ENABLE_WAYLAND=1 uses Firefox' experimental native Wayland EGL backend (bug 1543600) instead of Xwayland
  • media.ffmpeg.vaapi.enabled enables experimental VAAPI hardware video decoding (bug 1610199).
  • gfx.webrender.compositor lets the system compositor (Gnome Mutter) glue all tiles together to the one Firefox window, otherwise WebRender's internal Draw Compositor would it. (bug 1617498)

Unless you need anything else from me I would say feel free to close the ticket.
Thanks all for your help!

Thank you for reporting the bug!

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Resolution: --- → DUPLICATE
Duplicate of bug: 1726807
You need to log in before you can comment on or make changes to this bug.