Closed Bug 1727228 Opened 3 years ago Closed 3 years ago

Consider factoring ancestor transforms and resolutions in GetPaintedLayerScaleForFrame

Categories

(Core :: Layout: Scrolling and Overflow, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1732660
Fission Milestone Future

People

(Reporter: hiro, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In GetPaintedLayerScaleForFrame we use the in-process resolution and ancestor transforms in the same process, that means it doesn't properly handle OOP iframe cases.

Attaching file has a changeset to add a reftest, the reference file opens an in-process iframe loading a test case introduced in bug 1012752 (the bug originally introduced relevant code in question) and the test file loads the same test case in a cross-origin iframe, thus GetPaintedLayerScaleForFrame returns different values in those cases.

That said, the reftest fails on non Fission too I don't quite understand what makes the test fail. I am not sure where the underlying issue is. So I am not particularly concerned this issue for Fission.

Fission Milestone: --- → Future
See Also: → 1727229

Looks like this is being taken care of in bug 1732660.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: