Fix to IMAP server directory that makes INBOX appear on same level as other folders no longer works. Courier-IMAP server.

RESOLVED DUPLICATE of bug 165253

Status

MailNews Core
Networking: IMAP
--
minor
RESOLVED DUPLICATE of bug 165253
15 years ago
9 years ago

People

(Reporter: Chris A. Johnson, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826 WebWasher 3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826 WebWasher 3.0

I am accessing a Courier-IMAP server, v.1.5.0. The previous fix to make INBOX
appear "correctly":

1. Change the "IMAP server directory" to "INBOX." (without the quotes, with the
period).
2. Remove entries under "Personal namespace" and "Public (shared):"
3. NOT Checked - "Allow server to override these namespaces"
4. Check - "Show only subscribed folders"
5. Check - "Server supports folders that contain sub-folders......"

This worked up through Mozilla 1.1Alpha. After installing 1.1Beta problems
appeared. I only used "official" builds, never nightly ones. The problem still
exists in "official" Mozilla 1.1. I have not tried 1.2Alpha.

Using the same prefs.js file, Mozilla 1.1Beta and higher does not behave
normally. Each time Mozilla is closed entirely and re-opened, the folder views
disappear. Only "Inbox" and "Trash" show up. They can be forced to reappear by
clicking the arrow next to the server twice (to minimize and maximize it). All
of the message headers must be re-downloaded each time.

Reproducible: Always

Steps to Reproduce:
1.Configure Mozilla 1.01 to access a Courier-IMAP server as above. Drafts, Sent,
and Trash (and other top-level folders) should appear on the same level as Inbox.
2.Upgrade to Mozilla 1.1.

Actual Results:  
On accessing the mailbox, only Inbox and Trash will appear. Other folders will
appear if you refresh, but their messages headers need to be downloaded. This
happens EVERY time Mozilla is closed and re-opened. (Note, if you close mail,
but leave the browser open, then re-open mail, it does not happen).

Expected Results:  
Mozilla should correctly display Inbox and subfolders as it does in version 1.0
and 1.01.

Although this is a minor bug, I find it highly annoying since it was working
perfectly in Mozilla 1.0 (and 1.01). I just don't like having my Inbox be a
level higher than all other folders. Other mail clients get this right, what
happened to break it in Mozilla 1.1Beta?

Here's a workaround I've devised:

It puts Inbox off in it's own level again. But it retains the folder lists when
you exit and restart Mozilla.

Go to Mail & Newsgroup Account Settings->Server Settings->Advanced.
1. IMAP server directory should be blank
2. Check - Show only subscribed folders
3. Check - Server supports folders that contain sub-folders and messages.
4. Personal namespace: "INBOX."
5. Public (shared) and Other Users: should be blank
6. NOT Checked - Allow server to override these namespaces...
(Reporter)

Comment 1

15 years ago
IMAP Communication log located at Bug# 165253. Appears to be the same bug.
Yes, these do seem to be dups.

*** This bug has been marked as a duplicate of 165253 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.