Closed Bug 1727401 Opened 9 months ago Closed 6 months ago

Youtube vp9 hardware decode freeze (drops) with RTX 3000 series

Categories

(Core :: Audio/Video: Playback, defect)

Firefox 91
defect

Tracking

()

RESOLVED DUPLICATE of bug 1722171

People

(Reporter: vasilenkoeyu, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached file support.txt

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

With NVidia RTX 3000 series GPU youtube VP9 hardware decode acceleration causes freeze (frames drops in youtube statistics).
Issue reproduced on different PCs with RTX3060TI and RTX3070TI, not reproduced at same PC with GTX1070 or with disabled hardware acceleration in settings.
It seems that opening multiple video tabs makes things worse, freezes occurs longer and more often even if the video is on pause at other tabs.

Actual results:

The video freezes for up to several seconds, sounds playing without interruption. Noticed that youtube dropped frames counter increases immediately by the full number of dropped frames, for example: it increases by 300, and AFTER that the video is interrupted for 5 seconds, while the total frames count increases normally, 30 every half a second.

Expected results:

No drops with hardware acceleration by RTX 3000 series GPU.

The Bugbug bot thinks this bug should belong to the 'Core::Graphics' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Graphics
Product: Firefox → Core
Blocks: video-perf
Component: Graphics → Audio/Video: Playback

is this problem still exists? i think i duplicate with Bug1722171 and it should fixed now

(In reply to mix5003 from comment #2)

is this problem still exists? i think i duplicate with Bug1722171 and it should fixed now

Hi vasilenkoeyu,

Could you please download Firefox beta from https://www.mozilla.org/en-US/firefox/channel/desktop/#beta and see if it's fixed? Thanks a lot!

Flags: needinfo?(vasilenkoeyu)

Hello,

Thanks for feedback. I'm checking now FF 95.0b7 with latest (496.49) NVIDIA driver on RTX3060Ti, and see no such freezes with video playback from YouTube with enabled hardware acceleration, frames drop counter is between 0.1-0,2% of total frames count, increases slightly only when parallel activity in other FF window or tabs.

Flags: needinfo?(vasilenkoeyu)

Duping against bug 1722171 based on information above. Thanks for confirming!

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1722171
You need to log in before you can comment on or make changes to this bug.