Closed Bug 1727459 Opened 2 months ago Closed 2 months ago

Add more logs around WebRenderLayerManager::Initialize()

Categories

(Core :: Graphics: WebRender, task)

task

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox92 --- fixed
firefox93 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Crash of Bug 1707475 seems to happen by widget size in WebRenderLayerManager::Initialize(). Then it seems helpful to add logs around the widget size for estimating the cause of the crash.

Assignee: nobody → sotaro.ikeda.g
Blocks: 1707475
Attachment #9237895 - Attachment description: Bug 1727459 - Add more logs around widget size in WebRenderLayerManager::Initialize() → WIP: Bug 1727459 - Add more logs around widget size in WebRenderLayerManager::Initialize()
Attachment #9237895 - Attachment description: WIP: Bug 1727459 - Add more logs around widget size in WebRenderLayerManager::Initialize() → Bug 1727459 - Add more logs around widget size in WebRenderLayerManager::Initialize()
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b41457a3dc25
Add more logs around widget size in WebRenderLayerManager::Initialize() r=gfx-reviewers,jrmuizel
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Did you want to nominate this for release approval so it can ride along with an RC respin?

Flags: needinfo?(sotaro.ikeda.g)

Comment on attachment 9237895 [details]
Bug 1727459 - Add more logs around widget size in WebRenderLayerManager::Initialize()

Beta/Release Uplift Approval Request

  • User impact if declined: Start up crash of Bug 1707475 could happen. Crash report says that the crash was addressed with the fix, though I could not reproduce the crash locally.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch added just a simple error handling and logs.
  • String changes made/needed:
Flags: needinfo?(sotaro.ikeda.g)
Attachment #9237895 - Flags: approval-mozilla-beta?

Comment on attachment 9237895 [details]
Bug 1727459 - Add more logs around widget size in WebRenderLayerManager::Initialize()

Approved for 92.0rc2.

Attachment #9237895 - Flags: approval-mozilla-beta? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.