Status

()

defect
RESOLVED FIXED
17 years ago
8 years ago

People

(Reporter: blizzard, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Hang your xft bugs here!
Alias: xft_tracking
Depends on: 173204
Depends on: 128153
Depends on: 131466
Depends on: 175025
Depends on: 175690
Depends on: 176290
Depends on: 176382
No longer depends on: 177315
Depends on: 178128
Depends on: 179725
Depends on: 180328
Depends on: 180721
Depends on: 182650
Depends on: 182877
how do I add bugs here ? I wanted to add bug 182878
thanks
Depends on: 99823
Depends on: 183467
Depends on: 183468
Depends on: 183461
Depends on: 183206
Depends on: 182926
Depends on: 183729
Depends on: 183936
Depends on: 183750
Depends on: 184405
Depends on: 185350
Depends on: 185998
Depends on: 186210
Depends on: 190031
Depends on: 190278
Depends on: 190346
Depends on: 190347
Depends on: 190778
Depends on: 191972
Depends on: 191540
Depends on: 193276
Depends on: 193448
Depends on: 193973
Depends on: 194223
Depends on: 189948
Depends on: 194478
Depends on: 194511
Depends on: 195227
Depends on: 195268
Depends on: 187654
Depends on: 196031
Depends on: 196312
Depends on: 186704
Depends on: 197037
Depends on: 197095
Depends on: 195104, 195414
No longer depends on: 195104
No longer depends on: 195414
Depends on: 198123
Depends on: 198098
Depends on: 198200
Depends on: 198638
No longer depends on: 198638
Depends on: 203350
Depends on: 205621
Depends on: 207773
Depends on: 208606
No longer depends on: 208606
Depends on: 203683
I build mozilla using --enable-xft and I get weird behaviour when scrolling.  I
have noticed this bug since 1.2.  This is on a machine with linux 2.4, xfree86
4.3, gcc 2.95.3 and glibc 2.2.5.  I attach all the `configure' parameters I use
at the end.

First of all, with my xft-enabled builds, I get a blinking cursor everywhere,
even if I am not at a text input field. If I press page-down, the behaviour
depends on where the blinking cursor is; this is a bit complicated, I 'll try to
explain the best that I can.

For example, on slashdot there is a short `Sections' column at the left which is
shorter than the others.  If the blinking cursor is on that, then page down
doesn't work correctly; it shows the next page for 0.1 seconds and then returns
to the current page.  This doesn't happen if I first click on the longer central
column somewhere (where the main stories are).  I've noticed this problem on all
similar pages and I have to use the scroll-bar.

Pressing `space' also doesn't do anything, whereas till 1.0.x I always used the
space to scroll the page down.

I have not build mozilla without xft since 1.0.x, so I am not sure that this is
because of --enable-xft.  I am just guessing, since apart from `--enable-xft' I
use more or less the same configure options since 0.8.  Moreover, I've not
encountered the problem on other non-xft builds; I don't get any blinking cursor
and scrolling works perfectly.

The commands that I use in my spec file to build mozilla are:


export MOZILLA_OFFICIAL=1
export BUILD_OFFICIAL=1
export MOZ_INTERNAL_LIBART_LGPL=1

./configure \
	--prefix=%{_prefix} \
	--mandir=%{_mandir} \
	--enable-optimize=-O3 \
	--enable-strip-libs \
	--enable-nspr-autoconf \
	--enable-crypto \
	--enable-xft \
	--enable-reorder \
	--enable-strip \
	--enable-elf-dynstr-gc \
	--enable-cpp-rtti \
	--enable-extensions="all" \
	--enable-svg \
	--with-system-jpeg \
	--with-system-png \
	--with-system-mng \
	--with-system-zlib \
	--disable-debug \
	--disable-tests \
	--disable-jsd \
	--disable-mathml \
	--disable-accessibility \
	--disable-dtd-debug \
	--disable-logging
make
Depends on: 220582
Depends on: 213734
Depends on: 223653
Depends on: 227889
Depends on: 228783
Depends on: 229174
No longer depends on: 229174
Depends on: 229860
Depends on: 230215
Depends on: 230173
Depends on: 225489
Depends on: 231009
No longer depends on: 231009
Depends on: 234558
Depends on: 238508
Depends on: 238509
What about bug 236739? It seems like regression from bug 197037...
No longer depends on: 238508
Depends on: 229828
Depends on: 210513
Depends on: 240409
Blocks: 243227
Depends on: 252033
I am under the impression that Xft has long since been superseded by some combination of freetype, pango, cairo, and harfbuzz.  Does it still make sense to keep this bug and/or its dependencies open?
... also I don't know what it's doing under XUL.
Component: XUL → Graphics
QA Contact: jrgmorrison → thebes
XFT is no more.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.