Closed Bug 1727741 Opened 1 year ago Closed 1 year ago

if account setup wizard was not closed, trying to set up a new account will just show the "finish" page

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird92 affected)

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird92 --- affected

People

(Reporter: mkmelin, Assigned: aleca)

References

Details

Attachments

(1 file)

After successful setup of an account, I left the account setup tab open and removed the account I had set up. Then I went to set up an account again, but it still shows me the "finish" page.

After account setup is finished, if the tab is requested again, it should start from the beginning.

Ah, how did I miss this user flow?
Thanks for the report.

Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 93 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/4b929a6718c7
Reset the account setup on clicking 'add new email account' if tab is still open on the finish page. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Should uplift this.

Please request uplift.

Comment on attachment 9238253 [details]
Bug 1727741 - Reset the account setup on clicking 'add new email account' if tab is still open on the finish page. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug -
User impact if declined: If the user wants to add another email account without previously closing the successful account tab, the wizard will not reset.
Testing completed (on c-c, etc.): on c-c and beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9238253 - Flags: approval-comm-esr91?

Comment on attachment 9238253 [details]
Bug 1727741 - Reset the account setup on clicking 'add new email account' if tab is still open on the finish page. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9238253 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.