Closed Bug 1727777 Opened 1 year ago Closed 1 year ago

Calendar/Tasks import issue with thunderbird 91.0.3: TypeError: a.startDate is undefined

Categories

(Calendar :: General, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1727938

People

(Reporter: thomas.villatte, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36

Steps to reproduce:

Try to import tasks in a calendar : "Events and Tasks" then "import" then I select the tasks_TV@novespace.fr.ics file (the importation works with this file in Thunderbird 78.13). Then the importation window open but the list of items stays empty.
An error happen in the error console (copy hereunder):
Uncaught (in promise) TypeError: a.startDate is undefined
setUpItemSummaries chrome://calendar/content/calendar-ics-file-dialog.js:149
setUpItemSummaries chrome://calendar/content/calendar-ics-file-dialog.js:148
onWindowLoad chrome://calendar/content/calendar-ics-file-dialog.js:78
loadEventsFromFile chrome://calendar/content/import-export.js:37

I also noticed another error in the error console :
Calendar: Couldn't find W. Europe Standard Time 1

Actual results:

The list of items in the importation window stays empty.

Expected results:

The list of items should appear in the importation window.

Component: Untriaged → General
Product: Thunderbird → Calendar
Summary: Calendar/Tasks importation issue with thunderbird 91.0.3 → Calendar/Tasks import issue with thunderbird 91.0.3: TypeError: a.startDate is undefined
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1727938
You need to log in before you can comment on or make changes to this bug.