crashes printing any email [@ nsPrintingPromptService::OnStateChange]

RESOLVED FIXED in mozilla1.2beta

Status

()

Core
Printing: Output
P1
critical
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Andrew Schultz, Assigned: rods (gone))

Tracking

({crash, regression})

Trunk
mozilla1.2beta
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
If I try to print any email message, Mozilla crashes.  It seemed to be limited
to plaintext, but now I crash printing any email.

linux trunk build 2002100208 does not crash.  2002100308 does crash.
linux trunk build 2002100421 still crashes.

bonsai says mailnews printing got shook up pretty good during that window (bug
158110)

debug build give approximately 2.5 billion of these:
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'JavaScript component does not have a method named:
"getImageSource"' when calling method:
[nsIXULTreeBuilderObserver::getImageSource]"  nsresult: "0x80570030
(NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "<unknown>"  data: no]
************************************************************
and then
###!!! ASSERTION: aWidgetView must have a widget: 'nsnull != widget', file
nsViewManager.cpp, line 1548
WEBSHELL- = 6
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../../../../dist/include/xpcom/nsCOMPtr.h, line 650
(Reporter)

Comment 1

16 years ago
Created attachment 101827 [details]
stacktrace

mPrintProgress is NULL
(Reporter)

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 2

16 years ago
further investigation shows that the JS Exception is Mailnews' fault.  it spews
that all the time.
(Reporter)

Updated

16 years ago
Keywords: regression
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2beta
(Assignee)

Comment 3

16 years ago
Created attachment 101976 [details] [diff] [review]
patch v1

When I fixed windows I should have fixed Linux. Simple just make sure it isn't
null befopre referenceing it. (on my S drive)
(Assignee)

Updated

16 years ago
Priority: -- → P1
(Assignee)

Comment 4

16 years ago
Created attachment 101978 [details] [diff] [review]
patch v2 (mac, unixshared, os2)

Almost made the same mistake twice, here is the same patch that is on Windows
for mac, unixshared and os2
Attachment #101976 - Attachment is obsolete: true
(Reporter)

Comment 5

16 years ago
is bug 172753 (probably) a dupe then?

Comment 6

16 years ago
Comment on attachment 101978 [details] [diff] [review]
patch v2 (mac, unixshared, os2)

r=dcone

Updated

16 years ago
Attachment #101978 - Flags: review+
(Assignee)

Comment 7

16 years ago
Andrew, I guess in a way it is....

Comment 8

16 years ago
Comment on attachment 101978 [details] [diff] [review]
patch v2 (mac, unixshared, os2)

sr=kin@netscape.com
Attachment #101978 - Flags: superreview+

Comment 9

16 years ago
*** Bug 172867 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
I've just marked Bug #172867 as a dup as it reports the same error, but it
happens when you select Window-Mail&Newsgroups.

Also, OS and PLATFORM should be ALL.
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 11

16 years ago
*** Bug 173143 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
*** Bug 172753 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 172867 has been marked as a duplicate of this bug. ***
Created attachment 102940 [details]
Tru64 UNIX's stack trace
I still see the crash on a Tru64 UNIX.
Stack trace is attched with comment #15.
(Reporter)

Comment 17

16 years ago
you're seeing 173519

Comment 18

15 years ago
*** Bug 167555 has been marked as a duplicate of this bug. ***
Crash Signature: [@ nsPrintingPromptService::OnStateChange]
You need to log in before you can comment on or make changes to this bug.