Closed Bug 1727838 Opened 5 months ago Closed 4 months ago

Inspector front never unregister its STYLESHEET resource listener

Categories

(DevTools :: Inspector, defect)

defect

Tracking

(firefox94 fixed)

RESOLVED FIXED
94 Branch
Tracking Status
firefox94 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-perf-stability-triage)

Attachments

(1 file)

I've not verified if that a real source of leak, but we should fix that.
We never unwatch this call:
https://searchfox.org/mozilla-central/rev/be9c0ff754a04b32226b68aa014a8137ac29bd53/devtools/client/fronts/inspector.js#54-67

Duplicate of this bug: 1728075
Assignee: nobody → poirot.alex
Attachment #9238458 - Attachment description: Bug 1727838 - [devtools] Avoid leaking InspectorFront via the STYLESHEET resource listener → Bug 1727838 - [devtools] Avoid leaking InspectorFront via the STYLESHEET resource listener.
Status: NEW → ASSIGNED
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af9245a56425
[devtools] Avoid leaking InspectorFront via the STYLESHEET resource listener. r=nchevobbe

Backed out for causing bc failures in browser_ext_addon_debugging_netmonitor

Backout link

Push with failures

Failure log

Flags: needinfo?(poirot.alex)
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7d05daba1e2c
[devtools] Avoid leaking InspectorFront via the STYLESHEET resource listener. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Flags: needinfo?(poirot.alex)
You need to log in before you can comment on or make changes to this bug.