Links not "linkified" in mail & news messages unless format=flowed

VERIFIED DUPLICATE of bug 172808

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED DUPLICATE of bug 172808
15 years ago
13 years ago

People

(Reporter: Jerry Baker, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
mozilla1.2beta
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
2002100504 trunk.

Links (http://www.mozilla.org) are not being "linkified" when reading mail &
news messages. It just appears as plain ASCII text that requires copying and
pasting into the URL location bar to visit.

A search in MailNews for "links" did not turn up any duplicates.
(Reporter)

Comment 1

15 years ago
Created attachment 101828 [details]
Note the lack of clickability on the Bugzilla link
(Reporter)

Comment 2

15 years ago
This is caused by a message that doesn't have the Content-Type header (such as
Bugzilla mail). Mail with the Content-Type header correctly "linkifies" URL's.
(Reporter)

Comment 3

15 years ago
Ok. It gets weirder than that. It also fails for messages with the following
Content-Type header:

Content-Type: text/plain;
	charset="iso-8859-1"
(Reporter)

Comment 4

15 years ago
Sorry for all the spam. I got it definitively tracked down. If the Content-Type
header does not have format=flowed, URL's are not linkified.
Summary: Links not "linkified" in mail & news messages → Links not "linkified" in mail & news messages unless format=flowed

Comment 5

15 years ago
It happens with any mail in my Mailbox.
Including those without Content-Type an this ones:

"Content-Type: text" , 
"Content-Type: multipart/mixed; boundary="3d9162f32a4a"" ,
"Content-Type: multipart/alternative; boundary=boundary-BigSender"

Comment 6

15 years ago
E-Mail addresses are also affected by not beeing "linkified".

Comment 7

15 years ago
trunk 2002100508, Win2000
news with:
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable

quotes are not colored and links not "linkified"
This is a pretty serious functionality regression, particularly for those of us
who use Bugzilla :-)

Gerv
Severity: normal → major
Keywords: regression
Target Milestone: --- → mozilla1.2beta

Updated

15 years ago
OS: Windows XP → All
linux: wfm in 2002-10-04 05pdt cvs, broken in 2002-10-05 05pdt.
range 2002-10-04 05 / 2002-10-05 04:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2002-10-04+05%3A00%3A00&maxdate=2002-10-05+04%3A00%3A00&cvsroot=%2Fcvsroot
random guess - bug 172210?
CCing some people from bug 172210, which may have caused this regression.

Gerv
ducarroz, is this a dup of #172808?
yesy, this is a dup of 172808. we use a different patch for format=flowed which
explain why it was still working in that case.

*** This bug has been marked as a duplicate of 172808 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 13

15 years ago
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.