Closed Bug 1727916 Opened 2 months ago Closed 1 month ago

Some items are not sentence case in overflow menu's panel

Categories

(Firefox :: Menus, defect, P1)

defect

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- verified

People

(Reporter: ciprian_georgiu, Assigned: mhowell)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Attached image screenshot 1.png

Affected versions

  • latest Nightly 93.0a1
  • Beta 92.0b9
  • Release 91.0.2

Affected platforms

  • Windows 10 x64
  • macOS 11
  • Ubuntu 18.04 x64

Steps to reproduce

  1. Launch Firefox.
  2. Go to the Customize page.
  3. Drag & drop all the items to the overflow menu.
  4. Close the Customize page.
  5. Observe the elements from the panel and sub panels.

Expected result

  • All items are written in sentence case.

Actual result

  • Some items are not sentence cased in the panel and sub panel.

Suggested Severity

  • S4, since this won't affect affect the Firefox functionality or the end users.

Regression range

  • This is not a regression.

Additional notes

  • Please see the attached screenshots.

Molly, could you look in to this?

Flags: needinfo?(mhowell)
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Flags: needinfo?(mhowell)

This required migrating several strings to Fluent, and the bulk of this patch
is those migrations. The rest of the items matched up with an entry in the app
menu, so those items were switched over to use the app menu strings.

Setting to P1, since mhowell is clearly all over this.

Priority: -- → P1
Attachment #9239047 - Attachment description: Bug 1727916 - Convert several customizable toolbar item names to sentence case. r=Gijs → Bug 1727916 - Convert several customizable toolbar item names to sentence case. r=emalysz
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/63c10baf1578
Convert several customizable toolbar item names to sentence case. r=fluent-reviewers,flod,emalysz

Backed out for causing mochitest failures in en-US/appmenuitem-new-private-window2

Backout link https://hg.mozilla.org/integration/autoland/rev/14616096bc40dbbfe41f7dd366d167e6711e9c88

Push with failures

Failure log

Flags: needinfo?(mhowell)

The error in the logs is that a Fluent variable didn't resolve, but that's not the real problem; the real problem is that I accidentally added a tooltip to an app menu item, which aren't supposed to have any. The fix then will be to stop that from happening.

I've submitted a patch that seems to fix these failures, but the change is significant enough that I've re-requested review for it.

Flags: needinfo?(mhowell)
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33d959e23d7e
Convert several customizable toolbar item names to sentence case. r=fluent-reviewers,flod,emalysz
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

The patch landed in nightly and beta is affected.
:mhowell, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(mhowell)

I can confirm the items inside the overflow menu are in sentence case across platforms ( Windows 10, Ubuntu 18.04, macOS 12.0 - 21A5506j version) with the latest Nightly build. But the Manage account inside the Synced Tabs subpanel is no longer left aligned. Is this intentional? Or should I fill a separate bug for it?

(In reply to Release mgmt bot [:sylvestre / :calixte / :marco for bugbug] from comment #11)

The patch landed in nightly and beta is affected.
:mhowell, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

It is not important enough, no.

(In reply to Anca Soncutean [:Anca], Desktop Release QA from comment #12)

Created attachment 9240894 [details]
screenshot alignment.png

I can confirm the items inside the overflow menu are in sentence case across platforms ( Windows 10, Ubuntu 18.04, macOS 12.0 - 21A5506j version) with the latest Nightly build. But the Manage account inside the Synced Tabs subpanel is no longer left aligned. Is this intentional? Or should I fill a separate bug for it?

That is not intentional, no, and I have no idea how it happened; please file that and CC me, thanks.

Based on comment 12 I will mark this issue as verified fixed. For the additional encountered issue I've filled bug 1730835.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.