Closed Bug 1728018 Opened 1 year ago Closed 1 year ago

Thunderbird calendar not importing ics file with events and tasks

Categories

(Calendar :: General, defect)

Thunderbird 92
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1727938

People

(Reporter: jpastrano, Unassigned)

Details

Attachments

(2 files)

Attached file Work_26 July 21.ics

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

I attempted to import an ics file, which contains events and tasks, into Thunderbird 92.0b4 (16-bit), but the import never did anything. The .ics file was in my OneDrive, then I moved it to my desktop. To verify that the file contained info, I opened in Notepad and saw my calendar info. This verifies that the file is good.

Actual results:

When I started the import session, a note of "Loading items..." was displayed. That note stayed for a while. Then, I just clicked "Import All" thinking that would process the import and fill my calendar with events and tasks. That did not happen. I tried numerous times without success. Then, I left it importing overnight, but there was still no change. The import dialog box continues to note "Loading items..."

Expected results:

I expected the ics file to be imported with all of my events and tasks with ease. I've done it several times before without a problem and without delay in the import process.

I will add that I imported the ics file to my Google Calendar, then imported that calendar file to my Thunderbird and it worked (but it did not have any of the tasks). At least, it looks like it worked. I don't trust that it imported all of my original data in the ics file. For your info, I downloaded the original ics file from a Thunderbird beta, so I would expect Thunderbird beta to read its own ics file.

Bug 1727938? Check the Error Console.

Group: mail-core-security

(In reply to Magnus Melin [:mkmelin] from comment #1)

Bug 1727938? Check the Error Console.

Most likely. I've added a patch to Bug 1727938.

Reporter, please do Ctrl+Shift+I in main TB window, confirm remote dialog with OK, then switch to Console tab in Developer Tools.
Then try your STR, check error console, and report back here. Tia.

Depends on: 1727938
Flags: needinfo?(jpastrano)
Summary: Thunderbird calendar not importing ics file → Thunderbird calendar not importing ics file with events and tasks
I am unsure of what STR means, but I think I know what you want me to do.  I did as you suggest, and at the "try your STR," I attempted to import my ics file, but it failed.  Here is what the console recorded:

I am unsure of what STR means, but I think I know what you want me to do. I did as you suggest, and at the "try your STR," I attempted to import my ics file, but it failed. I attempted twice. Here is what the console recorded:

Calendar:
Parsing failed for parts of the item (while this is considered to be a minor issue, we continue processing the item): BEGIN:VCALENDAR PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN VERSION:2.0 BEGIN:VTIMEZONE TZID:America/New_York BEGIN:DAYLIGHT TZOFFSETFROM:-0500 TZOFFSETTO:-0400 TZNAME:EDT DTSTART:19700308T020000 RRULE:FREQ=YEARLY;BYDAY=2SU;BYMONTH=3 END:DAYLIGHT BEGIN:STANDARD TZOFFSETFROM:-0400 TZOFFSETTO:-0500 TZNAME:EST DTSTART:19701101T020000 RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=11 END:STANDARD END:VTIMEZONE BEGIN:VEVENT LAST-MODIFIED:20180107T112510 DTSTAMP:20171207T100334 UID:1512655200000-911790001 SUMMARY:Spr 18 Registration PRIORITY:1 STATUS:CONFIRMED DTSTART;VALUE=DATE:20180101 DTEND;VALUE=DATE:20180102 DESCRIPTION:Special Student, 5 Jan at 3:30 PM\nAshley Cohen Cavallo (0000 81738) 12819 DONE\nElizabeth Glenn , introPE DONE\nDon Abel (000099040) , 4635 NOT ADMITTED\n\nDrop/Add, 6 Jan at 8 AM\nSohaila (200046438) add 2342 …
CalIcsParser.jsm:159
Uncaught (in promise) TypeError: b.startDate is undefined
setUpItemSummaries chrome://calendar/content/calendar-ics-file-dialog.js:149
setUpItemSummaries chrome://calendar/content/calendar-ics-file-dialog.js:148
onWindowLoad chrome://calendar/content/calendar-ics-file-dialog.js:78
loadEventsFromFile chrome://calendar/content/import-export.js:37
doCommand chrome://calendar/content/calendar-command-controller.js:395
goDoCommand chrome://global/content/globalOverlay.js:129
oncommand chrome://messenger/content/messenger.xhtml:1
calendar-ics-file-dialog.js:149:5

(In reply to Thomas D. (:thomas8) from comment #2)

(In reply to Magnus Melin [:mkmelin] from comment #1)

Bug 1727938? Check the Error Console.

Most likely. I've added a patch to Bug 1727938.

Reporter, please do Ctrl+Shift+I in main TB window, confirm remote dialog with OK, then switch to Console tab in Developer Tools.
Then try your STR, check error console, and report back here. Tia.

Done. I added it as a comment.

Flags: needinfo?(jpastrano)
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1727938

Gave up with this. I downloaded Thunderbird 91 and imported the ics file with ease. It had all my calendar entries and event. I was amazed that the beta, which has been updated a few times since first reporting, still can't import the ics file. The beta won't even import the ics file I downloaded from Thunderbird 91.

No longer depends on: 1727938
You need to log in before you can comment on or make changes to this bug.