Collected addresses should be case-insensitive

VERIFIED DUPLICATE of bug 129393

Status

--
minor
VERIFIED DUPLICATE of bug 129393
16 years ago
9 years ago

People

(Reporter: shill, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In my "Collected Addresses" address book, I have multiple instances of the same
email address (only the case differs).

For example, I have user@cs.ucla.edu AND user@CS.UCLA.EDU. I think all addresses
should be converted to lower case before they are compared to the existing
addresses.

Comment 1

16 years ago
Please use the bug reporting guidelines and use the bugzilla helper. Which
version do you use?

pi
(Reporter)

Comment 2

16 years ago
I see what happened. I followed the "New" link from the page footer which links
to http://bugzilla.mozilla.org/enter_bug.cgi instead of
http://bugzilla.mozilla.org/enter_bug.cgi?format=guided

Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.1) Gecko/20020826

I searched Bugzilla but found nothing similar, which leads me to believe the
issue probably lives on in recent builds.

Comment 3

16 years ago
I see the problem with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b)
Gecko/2002100214. I found those double entries in my personal address book,
though. And I am 100% I did not add them.

There was a bug on this problem, so this here is a dupe, I cannot find it.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 95 → All
Hardware: PC → All
Whiteboard: DUPEME

Comment 4

16 years ago
Finally found.

pi

*** This bug has been marked as a duplicate of 129393 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 5

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
To the best of my knowledge this bug still exists in the main code.  To get it fixed please go to bug 129393 https://bugzilla.mozilla.org/show_bug.cgi?id=129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.