Last Comment Bug 172811 - "Current Downloads" (in downloads sidebar) is not updated when the path where the downloaded file is saved contains an accent
: "Current Downloads" (in downloads sidebar) is not updated when the path where...
Status: VERIFIED FIXED
:
Product: Toolkit
Classification: Components
Component: Download Manager (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: mozilla1.3a
Assigned To: Blake Ross
: Asa Dotzler [:asa]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 14:54 PDT by Sébastien Delahaye
Modified: 2008-07-31 01:47 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the bug (9.59 KB, image/png)
2002-10-05 14:58 PDT, Sébastien Delahaye
no flags Details
other sshot (1.29 KB, image/png)
2002-10-06 07:23 PDT, Sébastien Delahaye
no flags Details

Description Sébastien Delahaye 2002-10-05 14:54:57 PDT
UA : Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021005
Phoenix/0.3
Build from 2002/10/05

When you download a file, the "Current Downloads" space is not properly updated
if the save location path contains an accent.
The download progressbar stay gray, no percentage is displayed, and when the
download is finished, it stays in the "Current Downloads" space and doesn't go
to the "Finished Downloads" space.

To reproduce this, just create a folder which name contains an accent (like
"Sébastien" or whatever) and try to download files in it.

This happens since the downloads sidebar is in Phoenix. As far as I remember,
Mozilla's download manager had had the same problem, but it's fixed now.
Comment 1 Sébastien Delahaye 2002-10-05 14:58:41 PDT
Created attachment 101840 [details]
Screenshot of the bug

Attaching a screenshot.

Btw, I forgot to add that the "Cancel" link in "Current Downloads" doesn't work
for the downloads that have this bug.
Comment 2 Sébastien Delahaye 2002-10-06 07:23:05 PDT
Created attachment 101893 [details]
other sshot

I was wrong when I said that the finished download doesn't go to the "Finished
Downloads" section. It does move to this section, but
1. it is totally blank (see the new screenshot)
2. it also stays in the "Current Downloads" section (in the same state than on
the first screenshot: gray progressbar, no percentage, Cancel link, etc. It
doesn't show "finished" in bold as it does for other downloads).
3. if you close then reopen the downloads sidebar (ctrl+e 2 times), the file
isn't in the "Current Downloads" section anymore, but the empty line is still
in the "Finished Downloads" section.
Comment 3 Andrew Stegmaier 2002-10-20 11:20:47 PDT
I can reproduce this bug on the October 20, 2002 nightly build on Windows XP
Professional SP1.

I get the exact same behaveoir described in the Additional Comment #2 (emptey
line in the 'finished downloads section' and the current download entry
dissapearing after the toolbar is closed and re-opened

UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021020
Phoenix/0.3
Comment 4 Will Levine 2002-10-20 15:45:42 PDT
i can reproduce it with Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b)
Gecko/20021020 Phoenix/0.3.

however, when mozilla downloads something into an accented folder, the details
do not appear in download manager either (Mozilla/5.0 (Windows; U; Win95; en-US;
rv:1.2b) Gecko/20021020).

perhaps this is a mozilla problem. i could not find an existing bugzilla report
for this in mozilla.
Comment 5 Shawn Lindsay 2002-10-21 05:27:06 PDT
Reproducible on Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021020 Phoenix/0.3,
build 2002102008
Comment 6 Bugzilla FR 2002-10-24 08:51:05 PDT
Seems to work for me (on windows and linux with : 

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021023 Phoenix/0.3

See : Bug #176407 (duplicate) for additional comments.
 Philippe
Comment 7 Sébastien Delahaye 2002-10-24 08:58:20 PDT
Philippe, bug 176407 is not a dupe, it's something different.
Comment 8 David P James 2002-10-24 13:54:39 PDT
Marking bug as confirmed. I'm seeing this on Linux too; changing OS to all.
Comment 9 David P James 2002-10-24 13:55:34 PDT
By "Changing OS to all" I actually meant it... <sigh>
sorry
Comment 10 David P James 2002-10-24 13:57:30 PDT
What the? Now it got marked as WFM...

Reopening...
Comment 11 David P James 2002-10-24 13:58:55 PDT
... and now CONFIRMING


Sorry about all this Sébastien
Comment 12 Blake Ross 2002-11-09 20:16:40 PST
Fixed.
Comment 13 Sébastien Delahaye 2003-03-17 03:26:08 PST
v.

Note You need to log in before you can comment on or make changes to this bug.