IMAP inbox incorrectly reports number of unread messages

RESOLVED DUPLICATE of bug 133467

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 133467
15 years ago
10 years ago

People

(Reporter: Darin Fisher, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
IMAP inbox (nsmail-2) incorrectly reports number of unread messages.  I had this
problem w/ an older profile as well.  Creating a new profile fixed the problem,
but now I once again am seeing this problem.

For whatever reason, the folder pane indicates 1 unread message in my inbox;
however, there are no unread messages in my inbox.  In the past, I've seen it
incorrectly report several unread messages.  Pressing Get Msgs doesn't help.  In
the past, receiving new email messages also didn't help.  I'm seeing this with
the 2002-10-04 netscape commercial 1.0 branch build under win32.  I haven't
tried a trunk build yet.

IIRC this started happening after I checked my email using a different machine
while still viewing my inbox on the first machine.  Sequence of events like so:

1) check mail on machine A
2) check mail on machine B
3) check mail on machine A

possibly receiving email in between checks and deleting emails during checks.  
now the profile on machine A incorrectly indicates unread messages. 
unfortunately, i can't recall the specific events any better than that :(

Updated

15 years ago
QA Contact: gayatri → yulian
(Assignee)

Comment 1

15 years ago
taking - I'll try to recreate it by trying those steps.
Assignee: mscott → bienvenu
(Assignee)

Comment 2

15 years ago
Darin, if you're running a recent 1.3 build (11/18 or better), and still see
this problem (after deleting your inbox.msf), could you let me know? There's a
slight chance that I've fixed this while fixing another bug. Also, do you have
any mail filters on either machine? And when you say check mail, do you mean
bonk the get new mail button? And do you have check for new mail set as well? If
so, at what interval?
(Reporter)

Comment 3

15 years ago
>Darin, if you're running a recent 1.3 build (11/18 or better), and still see

2002111908 trunk on one... but still have BBird on the other (i'll switch).

>this problem (after deleting your inbox.msf), could you let me know? There's a
>slight chance that I've fixed this while fixing another bug. Also, do you have
>any mail filters on either machine? And when you say check mail, do you mean

yes, i have mail filters on both machines.

>bonk the get new mail button? And do you have check for new mail set as well? 
>If so, at what interval?

yeah, i meant the "get msg" button.  automatically checking every 10 minutes.

Comment 4

15 years ago
*** Bug 153490 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Deleting the inbox.msf (and other .msf files for folders having problems)
cleared up the issue for me.

Comment 6

15 years ago
this can also be remedied by unsubscribing from the folder (and any subfolders),
then subscribing again.

Until this is fixed, any chance of a "resubscribe" link on a folder that does
what I have described? I'm seeing this bug quite often as a delete large numbers
of emails from mailing lists after glancing through them. It seems to happen if
you start a new delete operation while one is in progress. I often use
shift-delete which might exacerbate it.

Finally, another symptom is that blank unread emails turn up in the folder in
place of deleted emails (ie no subject, un read, no sender, dat 1/1/70), but
these disappear after closing mozilla and reopening (but unread # is still
wrong). This may be unrelated as it doesn't always happen at the same time.

Comment 7

15 years ago
Dupe of bug 72114 or that is a dupe of this ?

Comment 8

15 years ago
I was one of the reporters of this a long time ago. I have not seen it for a
long while. But for the record, I often do have multiple IMAP sessions connected
to the same server, and some of them automatically check for messages. I also
have the message and junk mail filters enabled.

Comment 9

14 years ago
I just had this problem using Mozilla 1.5
My inbox stated there were 2 new messages, and a subfolder had 4 new messages.
Both of these were false. It happened when I was copying messages from my inbox
to the subfolder. I selected the messages I wanted to move (4 of them), then
draged them over to the left side (where the folders are), but let go before I
got to the folder. I did this again, but this time actually put them in the
folder. The next time I started Mozilla, it said there were these unread
messages (although there were none). There was also the unread message from
1/1/70 with no sender/subject/anything else. I followed the instructions and
deleted the .msf files Inbox.msf and subfolder.msf (in the folder before the
subfolder), and all is back to normal.
(Assignee)

Comment 10

14 years ago
Luke, do you know where you did drop the messages? Or was the drag drop cursor
the "no entry" sign when you let go of the mouse?

Comment 11

14 years ago
I've seen this with moz 1.5 on two separate machines now.  (or more correctly,
two different imap realms, 2 separate moz installs)

Both realms have a moz mail as the main mail reader, IMAP, but both are often
accessed via either webmail or pine, or another alternative.  One of them has
filters (on the mail server though) and the other has no filters at all.

Deleting Inbox.msf fixed it, though it certainly churned as it downloaded 15000
headers again :)  I'm afraid I've got no idea how I got into the situation though :(

Comment 12

14 years ago
This seems to be the same as bug 133467
Resolving as dup of bug 133467 as this does indeed appear to be the case.

*** This bug has been marked as a duplicate of 133467 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.