Closed Bug 1728429 Opened 3 months ago Closed 3 months ago

Updates to the Firefox Suggest Sponsored action text

Categories

(Firefox :: Address Bar, task, P1)

task
Points:
3

Tracking

()

VERIFIED FIXED
94 Branch
Iteration:
93.2 - Aug 23 - Sep 5
Tracking Status
firefox92 --- verified
firefox93 --- verified
firefox94 --- verified

People

(Reporter: adw, Assigned: adw)

References

(Blocks 1 open bug, )

Details

Attachments

(3 files, 1 obsolete file)

[Tracking Requested - why for this release]: This is required for the Firefox Suggest feature on 92.

We're dropping the part about the spacing around the Firefox Suggest group label for now, so I'll update the bug summary.

Summary: Updates to the Firefox Suggest group label and Sponsored action text → Updates to the Firefox Suggest Sponsored action text

Summary of changes:

  • Remove the Sponsored action text for Firefox Suggest sponsored results
  • Instead show Sponsored below their titles
  • Remove the Firefox Suggest action text for non-sponsored results

This uses ::after on row titles to show the Sponsored text. That seems simpler
than modifying the DOM.

I asked Natalie if we should use the same UI for sponsored top sites, but she
said to leave that alone for now.

Depends on D124300

This is an alternative approach to D124519. It uses the action text for
"Sponsored" as we do now, but it wraps it below the title.

I'm not sure which approach is better, but I made this one because I hit a test
failure with D124519 where the action text in an unrelated test was being
cleared. At first I thought it was related to not setting an action, but that
turned out not to be the case.

The Figma spec (link in Jira ticket) shows URLs in Firefox Suggest results, the
same as history results. I asked Natalie about it, and that's not correct, or at
least we shouldn't implement that now. If we do need to show URLs, then this
approach is probably worse than D124519 because wrapping the action would also
force the URL on a new line since the URL comes after it.

Attachment #9239435 - Attachment is obsolete: true
Attachment #9239508 - Attachment description: Bug 1728429 - Alternative approach: Update the Firefox Suggest Sponsored action text by wrapping the action text. → Bug 1728429 - Update the Firefox Suggest Sponsored action text by wrapping the action text.
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8135e9b2b8f
Update the Firefox Suggest Sponsored action text by wrapping the action text. r=dao
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+
Flags: in-testsuite+
Attached image screenshot

STR for QA

  1. Set browser.urlbar.quicksuggest.enabled = true
  2. Set browser.urlbar.quicksuggest.shouldShowOnboardingDialog = false
  3. Set browser.urlbar.suggest.quicksuggest = true
  4. Set browser.urlbar.suggest.quicksuggest.sponsored = true
  5. Restart
  6. Type "ebay" in the address bar and verify an eBay sponsored Firefox Suggest result appears last in the panel with the word "Sponsored" below the title; see attached screenshot
  7. Type "wikipedia" and verify a Wikipedia non-sponsored Firefox Suggest result appears last in the panel. "Sponsored" should not appear
  • I have verified this issue using the latest Nightly 94.0a1 build (Build ID: 20210907214756) on Windows 10 x64, macOS 11.4, and Ubuntu 20.04 x64.
  • The "eBay" sponsored Firefox Suggest result appears last in the panel with the word "Sponsored" below the title.
  • The "Wikipedia" non-sponsored Firefox Suggest result appears last in the panel, with no "Sponsored" label below the title.
Status: RESOLVED → VERIFIED

We're going to need to uplift this to an Fx92 dot release eventually. I guess the string changes aren't scary here because the experiment is targeting en-US only?

Flags: needinfo?(francesco.lodolo)

Though for the Beta/Release uplift, maybe we can just drop the firefoxSuggest.ftl changes entirely since it's just a string removal.

This removes a string from a preview Fluent file that isn't exposed to localizers, so we don't need anything special.

This file is not exposed to localization (for that, it would need to live in a locales/en-US folder), it's OK to uplift anywhere.

Flags: needinfo?(francesco.lodolo)

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]:
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Low risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This particular patch affects only the Firefox Suggest feature
[String changes made/needed]:

Attachment #9240390 - Flags: approval-mozilla-beta?

Comment on attachment 9240390 [details] [diff] [review]
93/mozilla-beta & 92/mozilla-release patch

Needed for experiments targeting Fx92. Approved for 93.0b3.

Attachment #9240390 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Moving tracking the metabug for this work.

  • I have verified this issue using the Beta 93.0b3 build (Build ID: 20210909185859) on Windows 10 x64, macOS 11.5.1, and Ubuntu 20.04 x64.
  • The "eBay" sponsored Firefox Suggest result appears last in the panel with the word "Sponsored" below the title.
  • The "Wikipedia" non-sponsored Firefox Suggest result appears last in the panel, with no "Sponsored" label below the title.

Comment on attachment 9240390 [details] [diff] [review]
93/mozilla-beta & 92/mozilla-release patch

Beta/Release Uplift Approval Request

  • User impact if declined: Needed for important rollouts on 93 and 92
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Please see comment 8
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This particular patch affects only the Firefox Suggest feature
  • String changes made/needed:
Attachment #9240390 - Attachment description: 93 patch → 93/mozilla-beta & 92/mozilla-release patch
Attachment #9240390 - Flags: approval-mozilla-release?
QA Whiteboard: [qa-triaged]

Comment on attachment 9240390 [details] [diff] [review]
93/mozilla-beta & 92/mozilla-release patch

Approved for 92.0.1.

Attachment #9240390 - Flags: approval-mozilla-release? → approval-mozilla-release+
  • I have verified this issue using the Candidate 92.0.1 build (Build ID: 20210920202613) on Windows 10 x64, macOS 10.15.7 and Linux Ubuntu 20.04 x64.

  • I have verified that the "eBay" sponsored Firefox Suggest result appears last in the panel with the word "Sponsored" below the title.

  • I have verified that the "Wikipedia" non-sponsored Firefox Suggest result appears last in the panel, with no "Sponsored" label below the title.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.