Scrolling selected text uses a lot of CPU

RESOLVED WORKSFORME

Status

()

Core
Selection
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Brian Matzon, Assigned: mjudge)

Tracking

({perf})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
1 - Go to the above site
2 - Select a couple of paragraps (the more, the worse)
3 - holding the mouse down, scroll up and down - to increase and decrease selection
Result:
 CPU usage goes way up

Using 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826'
on a Celeron 366 @ 550

Using IE produces no where near this CPU usage.

Further investigation showed that if the page is small the CPU usage is smaller,
even though the selection is the same... somehow the other elements are being
'fiddled' with...

Comment 1

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
I tried this, the CPU graph shot up and down again equally quickly when I
complete the selection test. However, I didn’t see any noticeable performance
hit (on a 900 Mhz Athlon), from the user perspective.

Updated

16 years ago
Keywords: perf

Comment 2

16 years ago
Jus for the record,  I'm not seeing a problem on Mac OS 9 (build 2002100108).
Both scrolling by page-up/down and the scrollbar is instantaneous (except for
that part in the middle with the Hebrew text, but that's for a different reason).

But extending a selection with page-up/down isn't possible on the Mac (it only
changes the view-point, not the selection), so we're not suffering from this
problem.

Extending a selection with the arrow-keys is very slow, because
single-line-scrolling has always been slow on the Mac. If I press down-arrow 10
times (very quickly or with auto-repeat), I'm not expecting to see 10 scrollings
(full-screen redraws or an optimized version thereof), but much less. But that
might be another bug, already it might also affect this one.
(Reporter)

Comment 3

16 years ago
Using latest build, I am no longer seeing this huge CPU usage... - bug seems to
have been fixed... Sorry for spam.

Comment 4

16 years ago
per reporter's comments, -> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.