Closed Bug 1728605 Opened 3 months ago Closed 3 months ago

Clean up some inconsistent method naming on WindowContext/BrowsingContext

Categories

(Core :: DOM: Navigation, task, P3)

task

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: nika, Assigned: nika)

Details

Attachments

(3 files)

No description provided.

These codepaths will never be taken with SHIP enabled, and this patch adds a
couple assertions to keep track of that information for when we rip out SHIP.

This method actually tracks whether the context is current, so it has been
renamed, and the behaviour has been inverted.

Depends on D124210

This makes the method's name more consistent with IsContentSubframe, and is
probably more clear than IsFrame (as a <browser> could be considered a frame).

Depends on D124211

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62e758932f64
Part 1: Add assertions to various non-SHIP codepaths, r=smaug
https://hg.mozilla.org/integration/autoland/rev/52fab476b34c
Part 2: Rename misleading {Window,Browsing}Context::IsCached, r=smaug
https://hg.mozilla.org/integration/autoland/rev/7cb6b2b14554
Part 3: Rename IsFrame to IsSubframe, r=smaug
You need to log in before you can comment on or make changes to this bug.