Closed Bug 1728624 Opened 3 months ago Closed 3 months ago

Crash in [@ getCurrentValueCB]

Categories

(Core :: Disability Access APIs, defect)

defect

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird_esr91 --- unaffected
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox91 --- unaffected
firefox92 --- unaffected
firefox93 --- fixed

People

(Reporter: kashav, Assigned: eeejay)

References

(Regression)

Details

(Keywords: crash, regression, topcrash-thunderbird, Whiteboard: [tbird crash])

Crash Data

Attachments

(1 file)

Crash report: https://crash-stats.mozilla.org/report/index/165536b8-ad0a-47d6-813e-086600210901

Reason: SIGSEGV /SEGV_MAPERR

Top 10 frames of crashing thread:

0 libxul.so getCurrentValueCB accessible/atk/nsMaiInterfaceValue.cpp:24
1 libatk-bridge-2.0.so.0 impl_get_CurrentValue ./obj-x86_64-linux-gnu/../atk-adaptor/adaptors/value-adaptor.c:144
2 libatk-bridge-2.0.so.0 impl_prop_GetSet ./obj-x86_64-linux-gnu/../droute/droute.c:364
3 libatk-bridge-2.0.so.0 handle_message ./obj-x86_64-linux-gnu/../droute/droute.c:597
4 libdbus-1.so.3 _dbus_object_tree_dispatch_and_unlock dbus/dbus-object-tree.c:1020
5 libdbus-1.so.3 dbus_connection_dispatch dbus/dbus-connection.c:4576
6 libatspi.so.0 message_queue_dispatch atspi/atspi-gmain.c:89
7 libglib-2.0.so.0 g_main_context_dispatch glib/gmain.c:4055
8 libglib-2.0.so.0 g_main_context_iterate.constprop.0 glib/gmain.c:4131
9 libglib-2.0.so.0 g_main_context_iteration glib/gmain.c:4196

Many crashes since the 20210827103653 build. Filing in Thunderbird::Disability Access since all crashes except 1 are in Thunderbird (the Firefox crash is https://crash-stats.mozilla.org/report/index/83d6efbb-9342-40aa-9efd-fe70f0210831).

Severity: -- → S2

First buildid to be crashing is 20210827103653 - bp-281cdbb9-85b7-4976-b12a-e3a2f0210830 Thunderbird 93.0a1

Flags: needinfo?(mkmelin+mozilla)

acc should be null checked it seems, but a bit unclear to me what to do for the null case

Component: Disability Access → Disability Access APIs
Flags: needinfo?(eitan)
Product: Thunderbird → Core
Assignee: nobody → eitan
Status: NEW → ASSIGNED

Yeah, looks like we dropped the null check that was there with the change in bug 1727643.

Assignee: eitan → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(eitan)
Assignee: nobody → eitan
Status: NEW → ASSIGNED
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60663818d80e
Null-check internal object in ATK value functions. r=morgan
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Thanks for the quick fix

Regressions: 1728940
You need to log in before you can comment on or make changes to this bug.