Closed Bug 1728671 Opened 3 months ago Closed 3 months ago

The test_toolchain_configure tests fail if the pytest "--capture=no" argument is used

Categories

(Firefox Build System :: General, defect, P3)

defect

Tracking

(firefox93 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: mhentges, Assigned: mhentges)

Details

Attachments

(1 file)

To reproduce:

  1. ./mach python-test -s python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py

Explanation:
This is because, we use tempfile.tempdir in configure code, even if it isn't populated yet.

In pytest, the default capture behaviour uses a tempfile function, which populates tempfile.tempdir. With --capture=no, that priming doesn't happen, and our tests fail.

Priority: -- → P3

The tempfile.tempdir cache value isn't always populated, but
tempfile.gettempdir() always is. They both provide the same result.

Assignee: nobody → mhentges
Status: NEW → ASSIGNED
Pushed by mhentges@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71a4111f6c4a
Use gettempdir() instead of tempdir r=firefox-build-system-reviewers,glandium
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
You need to log in before you can comment on or make changes to this bug.