Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 193638
16 years ago
9 years ago

People

(Reporter: David K Leikam, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910

This report might need to be split into: the bug itself; and the manner in which
it is presented.
Every time I start the browser, I get an error dialogue,
---------------------------- 
An error occured reading the startup configuration file. Please contact your
administrator.
line 125: SyntaxError: unterminated string literal.
user_pref("mail.server.server1.host
-------------------------

I have grepped and manually looked for this string, but can't find it in any
file. There's nothing to indicate what "startup configuration file" means.

Second, this error is presented in a window which refuses to come forward. I
have to minimize every other open window just to get to it, in order to dismiss
it. An error window like this should definitely assert itself to the front,
rather than hiding behind all other windows and refusing to come forward.

I reinstalled Mozilla, no difference. Reinstalled to a different (new)
directory, no difference. Reverted to a previous version, ditto.

Reproducible: Always

Steps to Reproduce:
1. Just start Mozilla
2.
3.

Actual Results:  
Error dialogue, shy and hiding in the background

Expected Results:  
Identified the filename of the offending configuration file, at minimum.
Reporter:
You "prefs.js" file is corupt.
This can happen if
a) your system crashes
b) mozilla crashes

Please try to repair the line in the file prefs.js (in your profile folder) or
create a new profile. You can also try to replace it with the copy of that file
(prefs.bak) but i think that is possible also corrupt now.)
The profile is not deleted if you deinstall mozilla

-> invalid (no bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 193638 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.