Closed Bug 1729153 Opened 3 months ago Closed 3 months ago

SeaMonkey 32x32 default icon has light stripe at the bottom

Categories

(SeaMonkey :: Themes, enhancement)

SeaMonkey 2.53 Branch
enhancement
Not set
normal

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
seamonkey 2.90
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: frg, Assigned: frg)

Details

(Whiteboard: SM2.53.10)

Attachments

(3 files, 1 obsolete file)

Some one in alt.comp.software.seamonkey thought that a SeaMonkey icon looks a little odd with a white dot at the bottom and yes it seems so for the 32x32 if you zoom it.

Attached patch 1729153-fixdefault32-25310.patch (obsolete) — Splinter Review

After hours of work I present the new 32x32 fixed icon.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: branding has a glitch
Testing completed (on m-c, etc.): 2.53.10
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: --

Attachment #9239467 - Flags: review?(iann_bugzilla)
Attachment #9239467 - Flags: approval-comm-release?
Attachment #9239467 - Flags: approval-comm-esr60?

Not as noticeable but 22px and 24px also have the gray dent at the bottom.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: even more branding grief
Testing completed (on m-c, etc.): 2.53.10
Risk to taking this patch (and alternatives if risky): trivial++
String changes made by this patch: --

Attachment #9239467 - Attachment is obsolete: true
Attachment #9239467 - Flags: review?(iann_bugzilla)
Attachment #9239467 - Flags: approval-comm-release?
Attachment #9239467 - Flags: approval-comm-esr60?
Attachment #9239474 - Flags: review?(iann_bugzilla)
Attachment #9239474 - Flags: approval-comm-release?
Attachment #9239474 - Flags: approval-comm-esr60?

Comment on attachment 9239474 [details] [diff] [review]
1729153-fixdefault32-v1_1-25310.patch

[Triage Comment]
LGTM r/a=me

Attachment #9239474 - Flags: review?(iann_bugzilla)
Attachment #9239474 - Flags: review+
Attachment #9239474 - Flags: approval-comm-release?
Attachment #9239474 - Flags: approval-comm-release+
Attachment #9239474 - Flags: approval-comm-esr60?
Attachment #9239474 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/a2b8048ed190
Fix gray bottom stripe in SeaMonkey default icons. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.90
Summary: Seamonkey 32x32 default icon has light stripe at the bottom → SeaMonkey 32x32 default icon has light stripe at the bottom

Hi again.

Others and I are still seeing this issue in "SeaMonkey 32x32 icon still glitched?" newsgroup thread in alt.comp.software.seamonkey newsgroup. I see it (seamonkey.exe) in my 64-bit W10 Pro (default DPI on a 1080 monitor [1920x1080]). I don't see this issue in my old, updated Debian Jessie v8 and a borrowed macOS Big Sur v11.6.1 though. Maybe they missed an icon?

Did a Windows icon get missed?

2 more evil icons were still hidden in the shadows of the source tree.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Minor cosmetic glitch in Windows and macOS only.
Testing completed (on m-c, etc.): 2.53.11b1 pre
Risk to taking this patch (and alternatives if risky): trivial.
String changes made by this patch: --

Attachment #9251760 - Flags: review?(iannbugzilla)
Attachment #9251760 - Flags: approval-comm-release?
Attachment #9251760 - Flags: approval-comm-esr60?

Comment on attachment 9251760 [details] [diff] [review]
1729153-2-fixdefault32-25311.patch [checked in comment 9 target 2.93a1 2.53.11]

[Triage Comment]
r/a=me

Attachment #9251760 - Flags: review?(iannbugzilla)
Attachment #9251760 - Flags: review+
Attachment #9251760 - Flags: approval-comm-release?
Attachment #9251760 - Flags: approval-comm-release+
Attachment #9251760 - Flags: approval-comm-esr60?
Attachment #9251760 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/a43fd00954e3
Part 2: Remove light stripe from SeaMonkey Windows and macOS 32x32 icons. r=IanN
Attachment #9251760 - Attachment description: 1729153-2-fixdefault32-25311.patch → 1729153-2-fixdefault32-25311.patch [checked in comment 9 target 2.93a1 2.53.11]
You need to log in before you can comment on or make changes to this bug.