Closed Bug 1729437 Opened 10 months ago Closed 10 months ago

Problem with sending all attachments (Content-Transfer-Encoding is incorrect for some attachments/messages)

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird93+ fixed)

RESOLVED FIXED
94 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird93 + fixed

People

(Reporter: pawel.pykalow, Assigned: rnons)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(5 files)

Attached image Bez tytułu.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.63 Safari/537.36

Steps to reproduce:

I have added 3 attachments to the message. No matter how many attachments there are, they always send only one.

Actual results:

After sending, the message contains only 1 attachment

Expected results:

There should be 3 attachments

See Also: → 1729432
Blocks: tb91found
Type: enhancement → defect

Hi Pawel, can you download a nightly from https://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/ (search for thunderbird-94.0a1.en-US.win64.zip), and see if you can still reproduce? Thanks.

Flags: needinfo?(pawel.pykalow)

Unfortunately version 94.0a1 also has the same bug.

Is it possible to share the attachments so that I can try to reproduce? Or share the problematic mail?

Notice the file size is 104K before sent, and 20.9K after sent. So seems you should be able to reproduce it with just 3.AHU-2_1000.vbw. Can you find out what's missing in the sent 3.AHU-2_1000.vbw? If you find the missing position, can you open the original 3.AHU-2_1000.vbw, copy a few texts around the missing position, save as a new vbw file, send it to see if it's modified after sent.

The solution to this problem is to change the value "mailnews.send.jsmodule" to false in the settings editor.

That's a workaround, the old sending code is likely to be removed in a year or two. I appreciate if you can help us find the root cause.

Attached file ahu-01.vbw
Assignee: nobody → remotenonsense

Thanks a lot.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(pawel.pykalow)
Regressed by: 1211292
Target Milestone: --- → 94 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/af194d10a997
Use the full body to pick encoding in MimeEncoder.jsm. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Comment on attachment 9240434 [details]
Bug 1729437 - Use the full body to pick encoding in MimeEncoder.jsm. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1211292
User impact if declined: Content-Transfer-Encoding is incorrect for some attachments/messages. Bug 1731007 is also affected by this.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): The code affects all message sending, but not risky.

Attachment #9240434 - Flags: approval-comm-esr91?
Attachment #9240434 - Flags: approval-comm-beta?
Duplicate of this bug: 1731072

Comment on attachment 9240434 [details]
Bug 1729437 - Use the full body to pick encoding in MimeEncoder.jsm. r=mkmelin

[Triage Comment]
Approve for beta

Attachment #9240434 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1731531
Summary: Problem with sending all attachments → Problem with sending all attachments (Content-Transfer-Encoding is incorrect for some attachments/messages)

Comment on attachment 9240434 [details]
Bug 1729437 - Use the full body to pick encoding in MimeEncoder.jsm. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9240434 - Flags: approval-comm-esr91? → approval-comm-esr91+
Duplicate of this bug: 1736818
You need to log in before you can comment on or make changes to this bug.