Closed Bug 1729500 Opened 5 months ago Closed 4 months ago

Stack traces are no longer recorded by the memory panel across reloads

Categories

(DevTools :: Memory, defect, P1)

defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox92 unaffected, firefox93 verified, firefox94 verified)

VERIFIED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- verified
firefox94 --- verified

People

(Reporter: ochameau, Assigned: ochameau)

References

(Regression)

Details

(Keywords: regression, Whiteboard: dt-perf-stability-triage)

Attachments

(3 files)

STR:

  • open a page
  • open memory panel
  • Turn on "record stack stacks" via the checkbox
  • reload the page
  • take a memory snapshot
  • Select View: Aggregate and Group by: Call Stack

ER: See some objects with call stacks

AR: We get the No call stacks found. Record call stacks before taking a snapshot. warning and none of the objects are with any stack.

Without this, server side target were breaking stack record in the memory panel.
We have to ensure toggling stack record ON before the page starts loading.

Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED

To help know if a given configuration is supported by the backend.

The Bugbug bot thinks this bug is a defect, but please change it back in case of error.

Type: enhancement → defect

Set release status flags based on info from the regressing bug 1702715

Changing severity to S2 because this is a severe impact. Thanks Alex for working on this!

Severity: -- → S2
Priority: -- → P1
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af5fbdc901eb
[devtools] Implement TargetConfigurationCommands.supports r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/2a0d5c83f586
[devtools] Fix stack recording in the memory panel. r=jdescottes

If we end up uplifting these fixes, we should tweak the backward compat comments.

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

The patch landed in nightly and beta is affected.
:ochameau, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(poirot.alex)

Comment on attachment 9239888 [details]
Bug 1729500 - [devtools] Fix stack recording in the memory panel.

Beta/Release Uplift Approval Request

  • User impact if declined: The memory panel would no longer record stack traces when doing a page reload.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: * open a page
  • open memory panel
  • Turn on "record stack stacks" via the checkbox
  • reload the page
  • take a memory snapshot
  • Select View: Aggregate and Group by: Call Stack

ER: See some objects with call stacks

AR: We get the No call stacks found. Record call stacks before taking a snapshot. warning and none of the objects are with any stack.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Mostly changes the memory panel itself. The changes outside of the memory panel are quite simple.
  • String changes made/needed: no
Flags: needinfo?(poirot.alex)
Attachment #9239888 - Flags: approval-mozilla-beta?
Attachment #9239889 - Flags: approval-mozilla-beta?
Attachment #9241104 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9239888 [details]
Bug 1729500 - [devtools] Fix stack recording in the memory panel.

P1/S2, low risk + tests, we are still in betas, uplift approved for 93 beta 8, thanks.

Attachment #9239888 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9239889 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9241104 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Reproduced with Firefox 94.0a1 (20210907214756) on Windows 10x64.
Verified fixed with Firefox 93.0b8 (20210921185902) and 94.0a1 (20210922094736) on Windows 10x64, macOS 10.15 and Ubuntu 21.04 by following the STR from comment 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.