Regression, can't walk into page with AccExplorer

VERIFIED FIXED

Status

()

Core
Disability Access APIs
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

16 years ago
When I open up a simple page and try to walk into the children by expanding tree
nodes (as opposed to dragging to target to an x,y location), it gets stuck and
won't open the ROLE_PANE node's children.
(Assignee)

Comment 1

16 years ago
Created attachment 101952 [details]
Simple test case
(Assignee)

Comment 2

16 years ago
Created attachment 102086 [details] [diff] [review]
prefix increment with test instead of postfix

Seeking r=/sr=
(Assignee)

Comment 3

16 years ago
Comment on attachment 102086 [details] [diff] [review]
prefix increment with test instead of postfix

Wrong patch
Attachment #102086 - Attachment is obsolete: true
(Assignee)

Comment 4

16 years ago
Created attachment 102091 [details] [diff] [review]
prefix increment rather than postfix.

This fix makes us exit the loop when we should.

Comment 5

16 years ago
Comment on attachment 102091 [details] [diff] [review]
prefix increment rather than postfix.

r=jgaunt
Attachment #102091 - Flags: review+
Comment on attachment 102091 [details] [diff] [review]
prefix increment rather than postfix.

sr=bzbarsky
Attachment #102091 - Flags: superreview+
(Assignee)

Comment 7

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

16 years ago
This regressted over a month ago. This reason we didnt' catch in with our
automated tests is that those only test the cross platform nsIAccessible layer.
They don't test the windows-specific MSAA/IAccessible layer, and that is where
the problem was.

Should we be doing some tests of that layer?

Comment 9

16 years ago
Brent please investigate w/Dharma adding some routine Windows tests to our routine
(Assignee)

Comment 10

16 years ago
The accexplorer.exe tool in the MSAA SDK  can test both the x,y object report as
well as walking into the tree. It can also save the tree as a text file, which
we could use for comparison.

The inspect.exe tool can test the reporting of accessible objects associated
with events.

Comment 11

16 years ago
-- Verified on latest mozilla trunk(20021111). I am able to walk into pages with
AccExplorer. Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.